SIP/2.0 404 Not_Found

Hi,

I’m facing an issue for the first time. I have a SIP trunk that is successfully registered with the provider. I’m able to do outgoing calls. Incoming calls are not working. Our SIP provider is giving us the below trace:

U 2017/06/15 11:18:04.732776 69.10.37.184:5060 -> OUR_IP:5060
SIP/2.0 404 Not Found.
Via: SIP/2.0/UDP ISP_IP;branch=z9hG4bKa042.dc260921.0;received=ISP_IP.
From: “011441143199998” sip:[email protected];tag=763e951e2e9380172eea6cad52226b3c.
To: sip:[email protected]_IP;tag=as7f3ca2a8.
Call-ID: DP1.192.4712263.
CSeq: 108426679 INVITE.
Server: FPBX-13.0.192.8(13.16.0).
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO, PUBLISH, MESSAGE.
Supported: replaces, timer.
Content-Length: 0.

here are the logs I get on my FreePBX:
[2017-06-15 21:35:06] VERBOSE[2171][C-000001ef] netsock2.c: Using SIP RTP TOS bits 184
[2017-06-15 21:35:06] VERBOSE[2171][C-000001ef] netsock2.c: Using SIP RTP CoS mark 5
[2017-06-15 21:35:06] NOTICE[2171][C-000001ef] chan_sip.c: Call from ‘marwan’ (ISP_IP:5060) to extension ‘OUR_DID’ rejected because extension not found in context ‘inbound_trunk_name’.

Both outgoing and incoming trunks are online:
cloudpbx*CLI> sip show peers
Name/username Host Dyn Forcerport Comedia ACL Port Status Description
inbound_trunk_name/marwan ISP_IP No No 5060 Unmonitored
outbound_trunk_name/marwan IP No No 5060 Unmonitored
2 sip peers [Monitored: 0 online, 0 offline Unmonitored: 2 online, 0 offline]

Any ideas?

In there…

This is normally your “from-trunk” or “from-somewhere-outside-the-PBX” context. Check your trunk definition and make sure your incoming context is set to something internal to your PBX.

OK. I’m afraid I don’t totally understand. Give me examples please? What exactly “incoming context is set to something internal to your PBX”?

Here is my trunk setup:

[inbound_trunk_name]
type=peer
insecure=very
nat=no
canreinvite=no
username=marwan
secret=password
host=ISP_IP
context=inbound_trunk_name

[outbound_trunk_name]
type=peer
insecure=very
nat=no
canreinvite=no
username=marwan
secret=password
host=ISP_Server_name
context=outbound_trunk_name

By the way, this is a fresh installation and I do not have any extensions created/configured.

1 Like

Change context line(s) to:

context=from-trunk

Thats works! I wonder why this happened. Below are the settings recommended by the ITSP:
[ISP_outbound]
type=peer
insecure=very
nat=no
canreinvite=no
username=your_name
secret=your_asterisk_password
host=sbc.voxbeam.com
context=ISP_outbound
[ISP_inbound]
type=peer
insecure=very
nat=no
canreinvite=no
username=your_name
secret=your_asterisk_password
host=95.211.119.240
context=ISP_inbound

1 Like

There are so many things wrong with that…

[ISP_outbound]
type=friend
insecure=invite,port
nat=depends on the needs of the Asterisk Server
canreinvite=no
username=your_name
secret=your_asterisk_password
host=sbc.voxbeam.com
context=from_trunk

Then, you can ignore the Inbound settings (leave them blank) altogether.

1 Like

Thanks. Fixing it now.

Remember to tell your ITSP. I think we answer a question like this from Voxbeam users every other month or so.