Siemens Optipoint DSS key not lighting up

I have just downloaded and set up from the FreePbx distro.

I’ve registered a snom 360 and an optipoint ecoPlus S

The BLF key works on the snom but not on the optipoint

I could do with a little guidence on setting up the optipoint if possible. I can make and receive calls.

It seems odd to me that on GUI of the siemens phone when I select a key as a DSS key it asks me for address of record (presumably extension number) Realm (presumably the IP address of the freepbx server) user (the extension number again) then it wants the password, but if I set up a BLF key on the snom all it wants is ext number and IP address.

the siemens phone won’t let me set up a DSS key unless I first set up a line key, I think I’m missing something here.

I’d have said that a BLF key (as snom refer to it) and a DSS key(as Siemens refer to it) were the same thing but I suspect that the siemens phone is doing something differend and registering as the extension that I am trying to set the DSS key to indicate.

any clues would be apreciated

Dave

You have to register to subscribe to a hint.

DSS stands for Direct Station Signalling. One touch access. BLF is Busy Lamp Field.

A DSS is a BLF+Speed Dial.

You would not want to enter the credentials of the line you are monitoring. You want to use the credentials of that phone. The SNOM subscribes to BLF’s on account 1 by default.

Does this make sense?

I can see that the phone could be registered to more than one system, and that you could want DSS keys to represent extensions on either system and so the phone must have the details of the system that the DSS key is representing as well as the extension number of the phone that the button represents.

my optipoint is 126
my snom phone is 127

if I look at the debug screen then I can see that when I go off hook with my siemens phone I get

== Extension Changed 126[ext-local] new state InUse for Notify User 127

if I delete the BLF key from the snom then I stop getting these messages.
So presumably when the phone registers if it has a button for extension XXX then it requests/causes these messages to be generated whenever the state of extension XXX changes?

I don’t get the messages when the snom phone state changes presumably because I don’t have the button set correctly.

When on the Siemens phone GUI I sellect a DSS key I have the following fields to fill in

address of record = 126
Realm = IP address of server (it changes it to "asterisk"
User ID = 126
Password ******
confirm password ******

If I fill them in as above then there is no where left to enter the extension number/details of the phone that I want to represent on the button, I tried putting 127 in the user ID box then swapping it to the address of record box but in either case I get a mismatch error in the debug screen, and it didn’t solve my issue.

If I enter the details of the phone that I want moniter (which is the opposite of what you told me to do(but i thought I’d try it)) then at least the LED does light when I press the DSS Key or dial 127, but it prevents the snom phone from ringing unless I re-register it and then that stops the LED from working when I dial 127.

I presume this is because I have both phones arguing for the same registration?

any further ideas/ clues please

Dave

I don’t think you are following me. It looks like you have to provide the authentication credentials and the extension you want to monitor, it does not reference a line appearance.

So the following:

address of record = 127
Realm = IP address of server (it changes it to "asterisk"
User ID = 126
Password ****** (password for peer 126)
confirm password ****** (password for peer 126)

Should do the trick

I had tried that, the button seems to work ok when I press it calls 127 but the led doesnt flash and when I go off hook with 127 the led still doesnt light, I also get the following message.

[2012-01-01 21:04:28] WARNING[17040]: chan_sip.c:13926 check_auth: username mismatch, have <127>, digest has <126>
[2012-01-01 21:04:28] NOTICE[17040]: chan_sip.c:24331 handle_request_register: Registration from ‘126 <sip:[email protected] Address>’ failed for ‘IPaddress:5060’ - Username/auth name mismatch