Setup incoming trunk with easybell on FreePBX12

I had a working asterisk freepbx system with UKDDI number as my incoming number and an intervoip account as the outgoing account. We shifted to an easybell trunk. I have been able to make outgoing calls after configuring it, but still I’m not able to make incoming calls.

I tried to configure it the same way as UKDDI, a trunk with just IP address ( and port number 5060.
Then an inbound route with the DDI number.

If I do this for easybell, i get that the number is not in use, …
I had entered my server address in the UKDDI settings in the UKDDI website. But, there is no provision like this in easybell. Does anyone have an idea of how differently should I configure this ?
I’m using PJSIP trunk and FreePBX12.