Setup Faxing

I know this has been covered many times, and i’ve gone over many many different resources for configuring, etc. Most seem to fail in one place or another, since a file/download location is invalid. Now maybe my problem is that this is a Trixbox…:slight_smile:

This is a pure POTS transmission, no SIP involved. I’m sending fax from a fax line directly into our Asterisk box, which has a TDM2413E (12 FXO/4FXS with Echo Cancel).

In the General Setttings, I setup the system to receive faxes, and to use my email address as to/from. In the inbound routes for that channel, I’ve setup a 3 second pause after answer so that normal call are not “waiting” too long before being answered. I’m also using nvfax to detect.

This is what we get while watching the system :

-- Redirecting Zap/5-1 to fax extension

== Spawn extension (from-pstn, fax, 0) exited non-zero on ‘Zap/5-1’
– Executing Goto(“Zap/5-1”, “ext-fax|in_fax|1”) in new stack
– Goto (ext-fax,in_fax,1)
– Executing StopPlayTones(“Zap/5-1”, “”) in new stack
– Executing GotoIf(“Zap/5-1”, “1?3:analog_fax|1”) in new stack
– Goto (ext-fax,in_fax,3)
– Executing Macro(“Zap/5-1”, “faxreceive”) in new stack
– Executing Set(“Zap/5-1”, “FAXFILE=/var/spool/asterisk/fax/1198958878.0.tif”) in new stack
– Executing Set(“Zap/5-1”, "[email protected]") in new stack
– Executing RxFAX(“Zap/5-1”, “/var/spool/asterisk/fax/1198958878.0.tif”) in new stack
Disconnected from Asterisk server

I’ve been to : - links for tx/rx broken. Also, since TB doesn’t leave asterisk source files behind, hard to patch what’s not there.

I’m almost at the point of ripping the whole thing out and going base CentOS with asterisk/Freepbx, but really like the endpoint management in TB…I rather not do that at this point, but it’s always an option…

Thanks in advance,


for starters, if your faxes are coming in on POTS and you have your zapata.conf setup properly then you probably don’t want to use nvfax detect, the zap detection should be more reliable.

Tried that, same result. I was playing with both settings, but same result. It attempts to answer, but then it crashes asterisk.

you’ve NOT provided the important details. you’ve said it is a Trixbox build, but using what versions of stuff? asterisk, zaptel, etc are needed to help you on this. There were releases of trixbox that screwed up the fax real bad so knowing which version you are at will help to start.

2.2.3 and earlier or 2.2.8 and later work. Values inbetween have issues from failing nicely to blowing chow and hanging (2.2.5).

TB provides everything you need to faxing if you have a good build.