Setup analog line as extension and place outgoing calls

First i would like to apology if its the wrong place to ask (not sure if its a FreePBX related problem but i have to ask somewhere). I am newbie and still flying blind so would like to ask for guidance - at least point me where to look for a solution.

I have Cisco SPA3102 and a RaspberryPi which runs FreePBX 2.10.1.4. One softphone is set up (it can receive and place calls through the PSTN line, thaks to a few online manuals. That is my setup - now my problems related to the analog phone:

  1. What i cannot do is dial using the analog phone which is connected to Cisco SPA3102. Should i alter the dial plans on SPA3102 - i doubt it because after editing the PSTN LIne dial plan i still get a busy tone after dialing a number. At all i am sure where FreePBX takes control and what should be altered on SPA2102.

  2. How to set the analog phone as extension in FreePBX in order to make it ring simultaneous with my softphone. At the moment it can ring if i set “PSTN Ring Thru Line 1:” to Yes from SPA3102 settings (which is something i doubt is right in configuration like mine - or it isnt?). Even hten i would still need to add it as extension in order to call it from the softphone.

I would appreciate any help!

Configuring the FXS port on the on the SPA should be pretty much the same as configuring the soft phone. You’ll need to configure an extension and provision the SPA.

To make it ring at the same time as the soft phone, you’ll want to create a ring group, put both extensions in the ring group and then point the inbound route to the ring group.

BF

@w5waf: Thank you! Simple as it can be :slight_smile:

I have one more problem - cannot dial a number if there is a prefix. Lets say i want to dial 123456 - it is possible but when dialing

  1. 00country _code123456 I get this voice message:
This dialing case is not allowed
2. +country _code123456 results in a strange beep sequence

I haven’t set any “Dialed Number Manipulation Rules” for the trunk and the outbound rule is only one with match pattern "."
I was thinking that this way the number will be dialed directly but looks like there is some other problem.

Yes, the “.” should match anything, but I’d say the right sequence is not getting to your provider. As far as I know, the voice message you are getting is not an asterisk message…at least Ive never heard it…That would mean its coming from your provider. Since you are using a POTS line I’ll bet your system is sending digits before the POTS line is ready to receive them. If you go to your trunk setup tab, you’ll see the option to prepend to the dial string. You’ll want to put one or more “w” in that box. Each “w” causes a short wait before proceeding. This allows the line to be seized before any dialing digits are sent. I usually start with 4 or 5 and then reduce them one-by-one until it doesn’t work and then add 1or2 back in.

BF