FreePBX | Register | Issues | Wiki | Portal | Support

Setting up Lets Encrypt

configuration
Tags: #<Tag:0x00007fb904968dd0>

(Ed) #1

I am trying to get the CA setup using LETS ENCRYPT and keep getting the following error:

There was an error updating the certificate: Please check http://fl-002-router-sopho1.dyndns-remote.com/.well-known/acme-challenge/_ZLiSRxoq7iTM4lmNH4YJAo1lKHSyKI-5zjE6nGQiM4 - token not available

From what I have read, the main problem seems to be the ability of LE to access 80 ad 443. I have verified that I can access the PBX portal on both ports and have associated the LE FQDN’s with the TRUSTED FW connection.

and have enabled the web and secure web interfaces to the INTERNET zone:

Seems like the public/private.pem files are getting updated:

Really hoping someone can point me in the right direction or to log files of where to determine why this error is happening. Made these config settings based on the input from several posts i have read.

Current FreePBX:
PBX Firmware: 10.13.66-21
PBX Service Pack: 1.0.0.0

Thanks.