Setting qualify_timeout for an aor

This is in regards to FreePBX 13.0.197.

I am trying to figure out syntax in the pjsip.aor_custom_post.conf config file to set the qualify_timeout to 6.0.

file: pjsip.aor_custom_post.conf


I apply this config, and ‘core restart gracefully’
I get the following error when pjsip.aor_custom_post.conf is read…

[2019-06-27 17:17:32] ERROR[20362] config_options.c: Could not find option suitable for category ‘0001501’ named ‘qualify_timeout’ at line 3 of /etc/asterisk/pjsip.aor_custom_post.conf

The “type=aor” is not the correct category obviously, so what should I be using…
Thanks in advance,

The brackets around the 0001501 didn’t show up.

file: pjsip.aor_custom_post.conf


Not a solution, but the stuff you’re trying to change should be in the existing [0001501] context in one of the existing contexts.

Although I doubt it, you you may also need to add (+) after the context to add it to the existing context from the standard conf file.

I tried that with no luck (i.e. no effect).

If you use the FreePBX gui to set a extension’s “qualify_frequency”, that parameter ends up in the pjsip.aor.conf file.

I really only need to set the “qualify_timeout=6.0” or something just longer than 3.0 secs.
I assumed that you would do that in the pjsip.aor_custom_post.conf.

Like I said, I don’t know what to set the “type=???” to. If you set it to ‘aor’, none of the endpoints will register. I have tried
and no errors were thrown, but the value did not change when I examine the aor values for that contact.

In regards to the

the (+) was required for other _post.conf config files. This was pointed out by tech support at Sangoma.

As far as I can tell, it’s not possible to change this value using the conf files.

I am kinda coming to the same conclusion.
I have tried lots of different permutations and combinations.

If I specify type=aor, which is in the asterisk docs for the type, the load fails since that endpoint/extension already has an aor defined from the pjsip.aor.conf…

Any ideas on how to up this to about 6 secs?
We have all mobile / cell data based endpoints, and the 3.0 secs is just a bit too low. Using Wireshark, I can see 90%+ need a timeout of 4-5 seconds since the 200 OK responses to the OPTIONS are all packed together either in the cell router or in the cell system…

Endpoints are constantly going Unreachable about 40 to 50 times a day as they move around in vehicles.

The only practical way with pjsip is to file a feature request to have the param settable in GUI per extension. Until then, you can control this value if using chan_sip extensions.

They are all chan_pjsip extensions. I ran into some issue a couple of years ago with the chan_sip and a bug. Can’t recall specifics. Ended up with chan_pjsip which worked fantastic. And seemed faster. I’ll have to dig around in old, old, emails and notes to see what the issue actually was…

Thanks for your help.
If you can think of any command line to perform this, let me know…


Do you have the syntax for the qualify_frequency and qualify_timeout used in chan_sip handy? for entering into the chan_sip “Other SIP Settings” fields… <== I assume this is where it would go…

I see the “Qualify Freq” in the
sip show peers xxxxxx

But no qualify timeout equivalent

Both those values are settable in the Advanced tab of the chan_sip extension.

Qualify = 6000 <== I assume this is in mSec
Qualify Frequency = 45 <== every 45 secs

Hate to bug you again,
I see the “Qualify Freq” in ‘sip show peer xxxx’
What / where to see qualify_timeout in asterisk CLI… Been digging through docs.

In summary:
So, the pjsip.aor_custom.conf and pjsip.aor_custom_post.conf can’t set the qualify_freq and qualify_timeout values when they are read in?

I did “manually” set these in the pjsip.aor.conf file (knowing that this file will get over written when a config is pushed from the GUI), and was able to have these param take affect…

I am thinking that there has to be some syntactic method of entering these in either the pjsip.aor_custom.conf or pjsip.aor_custom_post.conf files through the GUI.

I had done this in the pjsip.endpoint_custom_post.conf with the following syntax. This worked.
for this file, but it must have defaulted to “type=endpoint”



1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.