Setting "Occupied Lines CW Busy" Working On FreePBX15 With PJSIP?


(Jdennis) #1

Under “Advanced Settings” there is an “Occupied Lines CW Busy” option. It’s described as

KEYWORD:CWINUSEBUSY
For extensions that have CW enabled, report unanswered CW calls as busy (resulting in busy voicemail greeting). If set to no, unanswered CW calls simply report as no-answer .

We have this turned on, despite that, when someone is on the phone, has call waiting enabled and another call comes in, but doesn’t answer it, it’s not playing the “busy” greeting.

Is anyone running FreePBX15 with Asterisk 16 and PJSip that can confirm this feature is working for them? I don’t know if it’s a setting or config on our end or if it’s some sort of bug.


(Jdennis) #2

Does anyone have any insight into this? I retested again with all of the latest FreePBX / Asterisk updates and it’s still not working for us. Any guess into whether this is an Asterisk specific or FreePBX specific issue? Should I report a bug to one or the other?


#3

I observe the same behavior. It’s not an ‘issue’ for me, as my unavailable and busy greetings are the same; IMO it’s none of the caller’s business why I didn’t answer the phone.

However, this is clearly a FreePBX problem, not Asterisk. I have Follow Me always enabled with Ring Strategy ringallv2-prim and suspect that the bug may be related to paths through that logic. Do you see it on an extension without FM?


(Jdennis) #4

Thank you for your response. The extension I was testing this with yesterday does not have Follow Me turned on.

I find value in the separate greeting stating that “I’m currently on the phone”. In our company, people at our branches a lot of times have a hard time getting someone from corporate on the phone, they may take a different action if they know I’m on another call, vs. away from my desk potentially going to the bathroom, etc.