Setting Inbound Route

This might be the dumbest question out here but I can’t help it.

My provider has provided me with a DID and an IP Address from where he would send the calls.

I’ve set the inbound route as per instructions in the FreePBX module documentation -> (Inbound routes). Good version 2.5 points the inbound route automatically to the extension.

How do I accept his calls ?

I created a SIP TRUNK as INCOMING_SIP

host=Provider IP Address
type=peer
context=from-trunk
disallow=all
allow=g729

I’m not getting the calls at all.
Do I have to specify the context also? Is there anything else needed in the trunk setting ?

A couple of questions:

  1. Do you have a license for the g729?
    1.1 Or if you are in a country where you actually can install unlicensed g729, have you installed g729 at all?
    If you don’t have any g729 you would certainly not receive any calls as you have disallow=all before your allow=g729.
    1.2 Does your provider require g729?
  2. Your provider, doesn’t he require you to register?
  3. Have you tried to set the checkbox for Allow Anonymous Calls and see if that makes any difference?

Thanks !

OK , please find my response herein,

I have the g729 liscense and I’ve already tested my codecs with the other outbound trunks.

on the CLI doing, “core show translation” , I see the g729 codec installed and setup.

Also, when in a call, I do, " sip show channels" and I see the codec g729 being used.

I’m sure codec is not the issue.

My has given me the IP address only. He said that just allow anything coming in from this IP. I think thats what I did in the incoming trunk ?

On doing “sip show peers”, I see the trunk status “unmonitored”. Can this be the issue ?

Also, is the context=from-trunk OK ? or shall I change it something else like ext-did ?

On the FreePBX system status, I see the trunk online.

I’ve already allowed anonymous SIP calls

My provider is claiming that the call is being rejected by the box. However, from the asterisk log files, I don;t see the call coming in ?

I’m a bit perplexed on this one.

Start the asterisk shell with ‘asterisk -r’, then type ‘sip debug’ and make a call into your DID. You should see a lot of debug logs. After the failed call do a ‘sip no debug’ and look for an error in the /var/log/asterisk/full log file.

You should be able to see in the log file why the call fails.
Unmonitored is when you don’t use registration for the trunk.

Are you behind a firewall? If so, do you have NAT enabled in sip_nat.conf and have entered an externip= ?

Trunk Name : PSTN ( for exam )
Outgoing Settings

canreinvite=no
context=from-pstn
host=172.19.3.253
nat=no
port=5066
qualify=yes
type=peer
allow=g729

Incoming Settings

canreinvite=no
context=from-pstn
host=172.19.3.253
nat=no
port=5066
type=user
allow=g729
disallow=all

The setting in here that mean we no need user and pass for register. Every invite message will send to SIP trunk from VoIP gateway and back.

the IP 172.19.3.253 is my VOIP Gateway
my SIP server have IP 172.19.3.254.

Thanks all.

If you need buy the codec G729 license, please contact me :D. 8$ for one license.

Regarding.

Trungdt

[email protected]