Setting a different language then EN as default language


I have installed Trixbox CE and update to FreePBX and I tried to find a solution (different then overwriting all EN audio file with the IT audio file) to get IT language as default on all PLAYBACK messages.

I have put all IT file on the /IT subdirectory for all kind of messages and set on sip.conf under [general] language=it but the only changes is regarding the internal call PLAYBACK that is now in IT. Any inbound call is answered with the default setting in EN.

Please can you suggest me where I have to set the language for all PBX to be in IT.



Hello, I have the same issue, in asterisk 1.4 freepbx 2.4 , trixbox 2.6.07,
in sip.conf added language=it, but it change the language only for intenal calls.
Every inbound call from trunk has language in en.
someone has resolved this one?