Set PJSIP P-Asserted-Identity Header

pjsip
Tags: #<Tag:0x00007f7027e00198>

(Rabba Zabba) #1

Hi, this problem appears when I activate call forwarding (freepbx 14 and asterisk 16).

Our provider requires a certain value in the PJSIP P-Asserted-Identity (PAI) header and rejects invites otherwise.

When I do regular outgoing calls, the PAI value is ok and it works. (I use sngrep)

When I activate call forwarding in an extension, the PAI header suddenly contains the CID of the incoming call hat is being forwarded and the forwarded call then is rejected.

I am looking for the best way to leave the PAI header untouched or to manipulate it to the correct value. I have checked
https://wiki.asterisk.org/wiki/display/AST/Asterisk+16+Function_PJSIP_HEADER

the [macro-dialout-trunk-predial-hook] unfortunately doesn’t seem the right place to do this. I can’t modify the [func-apply-sipheaders] context because it is always overwritten when I start a new session. I could maybe configure in the [func-apply-sipheaders-custom] but don’t quite understand how to reach it.

Any help is appreciated!

Ryan


#2

Can you explain how you are enabling Call Forwarding? There might be different options available depending on that. There are some Caller ID related options in the trunk’s settings that could be worth looking at. There are also some CID settings in an extension’s FindMe/FollowMe section as well, but they might not be relevant for this setup.