Server Status Asterisk ERROR

Recently installed everything and it was good. I go to change the hostname from localhost to Asterisk and now it is giving this error. Tried searching around and nothing seems to fix it. The service was restarted and seems fine. I’m not exactly sure where else to check to fix this problem.

[[email protected] ~]# rpm -qa | grep dahdi
dahdi-firmware-oct6114-256-1.05.01-1_centos6.noarch
dahdi-firmware-vpmoct032-1.12.0-1_centos6.noarch
dahdi-linux-2.6.2-1_centos6.i686
dahdi-firmware-te820-1.76-1_centos6.noarch
dahdi-firmware-hx8-2.06-1_centos6.noarch
dahdi-firmware-oct6114-064-1.05.01-1_centos6.noarch
kmod-dahdi-linux-2.6.2-1_centos6.2.6.32_358.0.1.el6.i686.i686
dahdi-firmware-2.0.4-1_centos6.noarch
asterisk-dahdi-11.4.0-1_centos6.i686
dahdi-firmware-tc400m-MR6.12-1_centos6.noarch
dahdi-firmware-oct6114-128-1.05.01-1_centos6.noarch
kmod-dahdi-linux-fwload-vpmadt032-2.6.2-1_centos6.2.6.32_358.0.1.el6.i686.i686
dahdi-tools-2.6.2-1_centos6.i686
[[email protected] ~]# rpm -qa | grep asterisk
asterisk-odbc-11.4.0-1_centos6.i686
asterisk-sounds-extra-en-gsm-1.4.11-1_centos6.noarch
asterisk-sounds-moh-opsound-ulaw-0.0-4_centos6.noarch
asterisk-doc-11.4.0-1_centos6.i686
asterisk-sounds-core-en-gsm-1.4.21-1_centos6.noarch
asterisk-sounds-core-en-ulaw-1.4.21-1_centos6.noarch
asterisk-dahdi-11.4.0-1_centos6.i686
asterisk-voicemail-11.4.0-1_centos6.i686
asterisk-res_digium_phone-11.0_1.6.0-1_centos6.i686
asterisknow-version-3.0.0-1_centos6.noarch
asterisk-core-11.4.0-1_centos6.i686
asterisk-11.4.0-1_centos6.i686
[[email protected] ~]# cat /etc/grub.conf

grub.conf generated by anaconda

Note that you do not have to rerun grub after making changes to this file

NOTICE: You have a /boot partition. This means that

all kernel and initrd paths are relative to /boot/, eg.

root (hd0,0)

kernel /vmlinuz-version ro root=/dev/mapper/VolGroup-lv_root

initrd /initrd-[generic-]version.img

#boot=/dev/sda
default=0
timeout=5
splashimage=(hd0,0)/grub/splash.xpm.gz
hiddenmenu
title CentOS (2.6.32-358.11.1.el6.i686)
root (hd0,0)
kernel /vmlinuz-2.6.32-358.11.1.el6.i686 ro root=/dev/mapper/VolGroup-lv_root rd_NO_LUKS LANG=en_US.UTF-8 rd_NO_MD rd_LVM_LV=VolGroup/lv_swap SYSFONT=latarcyrheb-sun16 crashkernel=auto rd_LVM_LV=VolGroup/lv_root KEYBOARDTYPE=pc KEYTABLE=us rd_NO_DM rhgb quiet
initrd /initramfs-2.6.32-358.11.1.el6.i686.img
title CentOS (2.6.32-358.2.1.el6.i686)
root (hd0,0)
kernel /vmlinuz-2.6.32-358.2.1.el6.i686 ro root=/dev/mapper/VolGroup-lv_root rd_NO_LUKS LANG=en_US.UTF-8 rd_NO_MD rd_LVM_LV=VolGroup/lv_swap SYSFONT=latarcyrheb-sun16 crashkernel=auto rd_LVM_LV=VolGroup/lv_root KEYBOARDTYPE=pc KEYTABLE=us rd_NO_DM rhgb quiet
initrd /initramfs-2.6.32-358.2.1.el6.i686.img
[[email protected] ~]# [[email protected] ~]# rpm -qa | grep dahdi
-bash: [[email protected]: command not found
[[email protected] ~]# dahdi-firmware-oct6114-256-1.05.01-1_centos6.noarch
-bash: dahdi-firmware-oct6114-256-1.05.01-1_centos6.noarch: command not found
dahdi-tools-2.6.2-1_centos6.i686
[[email protected] ~]# rpm -qa | grep asterisk
asterisk-odbc-11.4.0-1_centos6.i686
[[email protected] ~]# dahdi-firmware-vpmoct032-1.12.0-1_centos6.noarch
-bash: dahdi-firmware-vpmoct032-1.12.0-1_centos6.noarch: command not found

Is there a DNS server resolving the hostname ‘Asterisk’?

I changed it on the firewall to a static IP with the Hostname. Is there another spot to check for that?

Does the firewall also provide DNS? Do you have other hostnames on your internal network that resolve to IP addresses?

I did the same thing. Wanted to change from localhost to something more descriptive… edited the file under /etc/sysconfig/network, then edited the /etc/hosts file to reflect the change. Issued the “init 6” command to reboot and CRASH! After hours of Internet research and plugging through .conf files I came across the /etc/amportal.conf, which finally led me to the solution:

# --- CATEGORY: Asterisk Manager --- # # Asterisk Manager Host # Default Value: localhost ASTMANAGERHOST=localhost

At the top of the file it clearly states that you should not edit this file, but to use the web GUI under “Advanced Settings”. Problem there is that by default the “read-only” fields are not displayed so at a glance it seems as if you can not edit this value. However, if you click to “Display Readonly Settings” and “Override Readonly Settings” you have the option to update the hostname value.
In my case I’d had enough fun, so I simply reverted back to having the server named “localhost”. Rebooted and everything was back to normal, errors went away, an I’m on to configuring further…

Hope this helps.

AsteriskNOW – Please make it possible to change the server’s hostname without breaking everything. This is a very misleading error that results in unnecessary troubleshooting, frustrations, and wasted time.

Don’t change the /etc/amportal.conf file since it has nothing to do with changing the hostname of your system.

Edit /etc/sysconfig/network and change the hostname there. Reboot.