Server hang on after few hours continuously

hi, everyone,
i have been sufferred for the asterisk hang on problem for so long and i just reinstalled the whole thing yesterday, but again this morning the server hangs on again, you could not call in through PSTN line and the ppl also could not call out throught the server, there is simply engaged dial tone when you try to do so. and the only thing i can do is to restart asterisk server after some hours or one day. i am using asterisk 1.2.17 + zaptel 1.2.16 + freepbx 2.2.1.

[[email protected] ~]# tail /var/log/asterisk/full
Apr 5 09:38:17 DEBUG[6351] manager.c: Manager received command 'Command’
Apr 5 09:38:17 DEBUG[6351] manager.c: Manager received command 'Command’
Apr 5 09:38:17 DEBUG[6351] manager.c: Manager received command 'Command’
Apr 5 09:38:31 DEBUG[6305] chan_sip.c: Stopping retransmission on '293c2fcd70fb

[email protected]
’ of Request 102: Match Found
Apr 5 09:38:32 DEBUG[6299] chan_iax2.c: Peer lastms 286, historicms 286, maxms 2000
Apr 5 09:38:34 VERBOSE[6262] logger.c: – Remote UNIX connection
Apr 5 09:38:34 VERBOSE[8867] logger.c: – Remote UNIX connection disconnect ed
Apr 5 09:38:35 DEBUG[6305] chan_sip.c: Stopping retransmission on '777d42677b83

[email protected]
’ of Request 102: Match Found
Apr 5 09:38:37 DEBUG[6305] chan_sip.c: Stopping retransmission on '03d3c07e09b3

[email protected]
’ of Request 102: Match Found
Apr 5 09:38:37 DEBUG[6305] chan_sip.c: Stopping retransmission on '525fcce86064

Any one please give me some advice on this? thanks so much really,

Yes U need to call the telco get to a level two tech.
lay out what you have and see if they can help you out.

Do not stress the asterisk issue as in most cases it scares them

using little trick to get them help, once you can Hang up and the lited pad goes off then you can start “tweakin” the setup

That log is nothing.
you need to look the server and give us more detail
what card??
is the cooling fan running??

Have you pulled the bard out and tested???

What have you done???

Well, bubba sorry for less completed information, today i reproduce the problem and i noticed in fact only the zap lines are hanged on.

The case is my incoming zap line is connected to follow me directly and if no one answers then the call will forward to one cell phone through another zap line, and if i hang up the call before the remote person pick up his cell phone. The two lines are virtualy dead as they never hang up.

i am using loop start in singapore location and i have
busydetect=yes
busycount=4
in my zapata.conf

and another case is related to follow me section as well, i dial in the follow me list and without remote answering i hang up the call, it will go ahead to execute the full follow me list and then it hang up.

so could it be a bug of zaptel or asterisk ?
johnny

NO not a bug it is your phone lines / settings…

You need to speak to your telco…you need to get the right seetings and make sure they are setup right

http://www.voip-info.org/wiki-Asterisk+Disconnect+Supervision

Yes, bubba, i also think so.
but what i should ask them as if ask them for whether they support loop start or kewlstart then they will probably confuse.

And in fact i tested with kewlstart and put hanguponpolarityswitch=yes and the call won’t hang up. Hence i guess it only supports loop start,
and if i input busydetect=yes and busycount=4 then it’s fine for just incoming call to single extensions, if i add on the follow me feature then again it won’t hang up…

GO get a cheap handset witha lighted dial pad
have someone call you, you answer the call and have the caller hangup if the lighted pad does not go off as soon the caller hangs up it is a telco issue. If it does then it your issue (could be the wiring is crossed or you have a bad drop from telco it does happen)

Bubba,
thanks so much for your kind assistance.
I tested with your suggestion with a analog phone and i call in with my cell phone, even i hang up my cell phone, i can hear the busy tone but the dial pad light is still there.
I also tried to dial from the analog phone to my cell phone and hang up my cell phone again and the result is the same.

So does it mean my telecom does not support disconnect supervision? Or i can personally call them and ask them to provide this function to me? Hence so far i only use loopstart and with busydetect and busycount in my zapata.conf.