FreePBX | Register | Issues | Wiki | Portal | Support

SensuSangomaCheckService CRITICAL: rsyslogd DOWN


(Marbled) #21

Hi Tom!

:wink:

I believe it is pretty common for people not to realize a “product” might be composed of smaller “products” and that these “products” might have their own version numbering…

Okie dokie…

There is not actually a service which must be started that way… What you most likely have to do now (I did not have the problem, I just tracked it down so I could not check if it was actually needed) is to restart Asterisk…

The easiest way would be to issue

fwconsole restart

Good luck and have a nice day!

Nick


(Tom Brock) #22

I did do the install command. a restart of the system and as of this second, a call did show up in the CDR so I am hoping that everything is good.

I am going to add some memory to this pc and see if that helps that issue any as it is running a little lite on ram anyway.
Dont have enough in it to handle it i am sure. its an older pc, and i thought it had more in it than it does.

Otherwise, I cant think of any thing else .

I am very grateful for all the time you have given to assist with my problems.

Regards
Tom


(Marbled) #23

Hi Tom!

:smiley:

When you installed the package it confirmed it did it and did not complain about it already being present, right?

How much RAM do you have in that system?

No problem!

I do ask a favor to ask of you if that is possible…

If, when you installed the asterisk13-odbc package, it installed it without complaining it was already present do you think you could please upload your post_upgrade log file to this ticket https://issues.freepbx.org/browse/FREEPBX-15819?focusedCommentId=110519&page=com.atlassian.jira.plugin.system.issuetabpanels%3Acomment-tabpanel#comment-1105191 .

I created that ticket when we noticed the asterisk*-odbc package was missing but unfortunately could not provide any logs (since I never had that problem on my system) and was unsuccessful to have someone else upload his log…

It would be very much appreciated if you could do it. @GameGamer43, a FreePBX dev, needs this in order to identify the situation that causes that missing asterisk*-odbc package…

Thank you and have a nice day!

Nick


(Tom Brock) #24

Hey Nick,
sorry for delay, Have had the babies this evening and with three of them, this old man cant bat an eye when I have them. There to fast and I am out numbered :wink:

Yea, there was no kickback when I installed the package… went right through that with no complaints at all.

I thought there was 4 gb in this old pc, there was only 1 gb, so jumped on Amazon and ordered 4 Gb for it to be here on Tue’s. Not sure how its running at all with only 1 Gb in the thing. I think someone had helped them selves to it after it was retired the first time.

I would be very glad to upload the log from the install. but you’ll have to explain where its at, and how to get it … I am just pecking my way through anything on this linux platform.

I am not really sure how I did do what we have done to get it going, other than you have taken control of my fingers and guided them . lol
So i would be very glad to give back for all your help.

Gratefully,
Tom


(Tom Brock) #25

I am about to scrap the whole thing, its to full of crap bugs to make it sensible.

every time i do anything with it, i just end up with everything breaking and why bother!!

This time, I went into module admin and wanted to disable, the Sipstation module, because I am seeing some things in the Asterisk log that concern me. and i think its related to that module.

it disabled, and then when i clicked to apply config, it sat a long time working, then i get a red banner, that was so big it covered 3/4 of the screen, and couldnt read it before it went away, then i get the same error again.

Error!

Error: Did not receive valid response from server

XHR response code: 500 XHR responseText: undefined jQuery status: error

Looks like there is still some buggy things and it may not be viable for me to try to use.


(Tom Brock) #26

Looks like every time I do anything, I have to do a fwconsole chown and let it set a long time then click retry before it will work.

better than last time though,


(Marbled) #27

Hi Tom!

so you are under the minimum system requirements…

I would wait until you upgraded the memory to decide that if I were you…

That said, if you have a simple setup installing from scratch might be a safer bet…

Like what, could you post them?

I have it disabled but I doubt it would produce anything concerning…

The only thing I removed because I had enough with the warnings it produced was iSymphony…

There are always some bugs but my guess is that your PC is out of resources (like memory…) or something in it is failing (HD, etc…). It looks like your upgrade went relatively smoothly but something is making your system unstable.

How stable was it when you were running FreePBX 13?

fwconsole chown?

What error message do you get that makes you think you should issue that command?

This command makes sure that the permissions of the files used by FreePBX are the right ones…

You definitely should not have to run this over and over unless your files system has corruption of some kind I guess…

Good luck and have a nice day!

Nick


(Tom Brock) #28

Hey Nick,

Yea, I thought that there was already 4GB in the system. I had ran it as a PIAF for some time with no problems.
I never had any issues and never had to do anything other than module updates and such.

I am about sure that there was 4GB in the thing, I really think someone raided it while it was offline and in storage room.

I had taken the box, running PIAF offline and retired it, about 8 months and I missed having the thing…
so I got it back out and decided I would do fresh install since that had been on it about 2, maybe 3 years.

So Memory to be here Tue’s according to Amazon.

I’ll hold out for that before I decide to go back to 13… it may very well be the issue.

I had been trying to look for those log files showing the install of the ODBC package… so I could upload them as you requested. I still have not found that.
but while looking, I noticed in the Asterisk log, some attempted connects to ip address’s not involved in my trunk or any of my systems… so I got to thinking it could have been something from that module.

[2017-09-30 16:41:25] NOTICE[32121] res_pjsip/pjsip_distributor.c: Request ‘INVITE’ from ‘“False” sip:False@XXX.XXX.249.51’ failed for ‘51.15.41.189:5221’ (callid: 1312583727) - No matching endpoint found

and a couple times in with those, it spoke of sipvicious. i was sorta reading between the lines, so thats why I tried to disable that module to see if it was from that.
I may have been wrong, maybe its from another module, thats what I wanted to narrow down… by diabling one at a time and checking if it continued.

I ran FreePBX for about a week before I did the upgrade to 14… never had a single glitch on 13… didnt even get any memory warnings on it…
made calls, all seemed to work, at least from what little I had done with it. made a few calls, .

that brings me to the fwconsole chown command.

once I had tried to apply configuration after I disabled the module. and it gave me the

Error!

Error: Did not receive valid response from server

XHR response code: 500 XHR responseText: undefined jQuery status: error

response… I left the pop up dialog in place, googled it, got the results on the community, all that i read said to do the amportal chown.
well, i remembered you saying that amportal wasnt used now, and it was fwconsole so i issued the command as root on the console, clicked retry on the web interface, and it went right through… and seems to have corrected the problem.

that was about the third time I had gotten that error when doign the upgrades for modules and things… if i dont do the chown command, then it causes other problems, like connecting to asterisk failes and two other errors…

so thats why i had tried that.

now, to figure out if those lines are still hitting the asterisk log, i may not have had the right module, and that may even be normal for the system.


(Marbled) #29

Hi Tom!

(Geez, I just lost part of this email content, I am trying to remember everything I typed the first time…)

The issue might also be a failed upgrade so if you reinstall you could directly install FreePBX 14 instead of upgrading…

Thank you!

To find those type

updatedb 
locate post_upgrade

This will tell you where the file is…

It’s probably not necessary to run updatedb but I want to be sure the index used by locate is up to date…

That kind of error can be caused by a mixup between chan_sip and res_pjsip which are two SIP implementations we can use… It tries to talk to one when it should talk to the other…

That said, in this case that IP address is from the Netherlands and I believe you are in the US so it is more than likely an hack attempt…

Your SIP ports should not be opened to the whole Internet like they appear to be…

Did you specifically open them on your firewall?

If you did not it means that you have a (r@ppy firewall which opens port to the whole Internet when your system initiate a communication to the outside and it has to allow the traffic back in…

Usually it should limit it to only the outside IP your system talk to but some (r@ppy consumer router open the involved ports to the whole Internet and make your system open to attacks…

There’s a thread about this somewhere on this forum but I can’t seem to find it right now…

If you don’t use SIPstation you can disable it is not to blame here…

Did you try this as well?

Make sure you let the boot complete entirely before paying attention to the Asterisk connection failures…

(like wait for like 2 minutes once you know the system has rebooted…)

I can get those kind of failures if I access FreePBX before everything has finished starting up…

As I said above not normal and it appears to be an hack attempt…

What kind of firewall do you have?

Good luck and have a nice day!

Nick


(Tom Brock) #30

Hey Nick,

Yea, holding off on anything till the RAM is in, no since in fighting a loosing battle. lol

when I run the locate command, it shows me 4 files,

/etc/my.cnfpost_upgrade
/etc/my.cnfpost_upgrade2
/usr/sbin/glibc_post_upgrade.i686
/usr/sbin/glibc_post_upgrade.x86_64

but from there, not sure how to get them, or copy contents to upload or how…

Yea, I am in USA… That is what I was trying to narrow down, was it a module trying to do something it was supposed to do, or was it a hack attempt.

I use a new linksys router and firewal. but during setup. somewhere it said to put the ip address of the PBX on demilit zone, and let the built in firewall handle security. so thats what I did.

I do however, use softphone software on my cell when away from home to still be able to answer calls if someone calls the pbx number, and act as a standard extension.

I had not seen the chown -R… /session command , will try that if it happens again.

I dont think its just a matter of being to fast, i had let it set for 30 mins and still have the con not connect to asterisk error. till i do that command and it seems to resolve it until i get the error saving something agian.

Hope that was everything, Like i said, not really going to do anything till the RAM is in since I know that is not enough to handle it all… thats gootta be resolved first.

Regards
Tom


(Marbled) #31

Hi Tom!

It looks like you no longer have the file… :disappointed:

If this is a regular consumer router this is exactly what you don’t want to do…

A real DMZ is on a different network subnet than your main network is and frequently has tighter rules than it…

re: https://en.wikipedia.org/wiki/DMZ_(computing)#Rationale

A regular consumer router definition of a DMZ is a host to which everything which is not handled by another device on your network is forwarded to a specific IP address…

re: https://en.wikipedia.org/wiki/DMZ_(computing)#DMZ_host

A real DMZ makes your network more secure, the consumer router definition of a DMZ does almost the exact reverse…

With the router you have it is quite likely that the only thing you can get is the unsafe DMZ variant so I would get your server out of the DMZ and it should still be able to work correctly, when your PBX open a connection to the outside it should allow the response back in…

(Hopefully only from the IP of the external server only but some routers fail to do that…)

Actually putting your PBX in the DMZ has most likely opened your PBX web interface from the outside as well since those consumer routers forward to the DMZ anything which is not forwarded elsewhere so you are doubly at risk of getting hacked…

The PBX itself has a firewall you can use but I have no experience with it (I use pfSense, a firewall software you can install on a dedicated PC) and I can tell you it is not currently blocking those SIP hack attempts…

If it is only to answer calls you can have the PBX [quote=“WQGJ587, post:30, topic:44451”]
Hope that was everything, Like i said, not really going to do anything till the RAM is in since I know that is not enough to handle it all… thats gootta be resolved first.
[/quote]

Good luck and have a nice day!

Nick


(Tom Brock) #32

Hey Nick,

Just wanted to give you a fast update.

1, Confirmed that the RAM was stripped out of this box while in storage, found the fella that did it.

2… New RAM in box, and Fresh clean install.

Things seem to be running ok with it now… I am not getting one error right after the other.

  1. I think I found a solution for the security issue that I was having. At least I am not seeing those hacking attempts that I did before.

Thanks for everything
Regards
Tom


(Tom Brock) #33

And thats it, i give up, going to run 13 and forget it,

Tnight, since there had been no problem, i let it update all the modules … and boom
right back to , “Can not connect to Asterisk” errors again

oh well…
Maybe one day it will be there, but for now, for me, its not

Tom