Sendmail-gcloud script not transcribing during run

voicemail
Tags: #<Tag:0x00007fafc49b6d08>

(Andrew E) #1

I have been using @lgaetz excellent sendmail-bluemix script to transcribe voicemails for a couple years however I’ve started to get annoyed with IBM’s %HESITATION constantly (yes I realize I could write something into the script to remove it) however I figured that google could probably generate more accurate results hence the last 6 hours of going in circles and pulling my hair out trying to get sendmail-gcloud working.

It creates the flac file which I can add a line to copy to another location then run the gcloud ml speech recognize stream.part3.flac --language-code='en-US' on it as the asterisk user and get a result however it will not seem to run/return anything inside the script. The script is owned by asterisk:asterisk 755.

Does anyone have any Idea of what stupid thing I might be missing that is stopping the command from running inside the script? I’ve tried saving out to a file and then cating back in like the bluemix script, using /usr/sbin/gcloud, adding a wait to the script after the bluemix cmd, and another bunch of little tweaks I can’t even remember now (probably some of them 2 or 3 times by now.


(Andrew E) #2

Ok update I decided to try the last stupid thing I should have tried yesterday “reboot -h now” when the system came back up I called into a voicemail box and left a message and low and behold it transcribed it.


(system) closed #3

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.