Sending semicolon ; in header

Hello everyone,
I need to send an “X-UserToUser”-header in INVITE request, so I created in my extension_custom.conf the following line:

exten => addheader,1,Set(PJSIP_HEADER(add,X-UserToUser)=05064079017007F2;encoding=hex)

I think the problem is the semicolon ; It places a comment and the header isn’t added to the INVITE. I also tried to encode with % hex codes, but this also don’t seem to work.

exten => addheader,1,Set(PJSIP_HEADER(add,X-UserToUser)=05064079017007F2%3Bencoding%3Dhex)

I also tried both variants with quote marks ", but this is also not working. It is sending “as it is”.

Do you have any ideas what I could try next?
Thank you very much!

I think you can try escaping the ; with , so have it like

I tried


but no sucess. I also tried


But also no sucess…

Sorry I meant to say the other way around (slash in front):

Does that work? Trying to get it so I can type that without it removing from my post here haha. Guess I have to take a screenshot of Notepad. Probably something simple to make it show here.


1 Like


Thats it! Thank you very very much!

1 Like

Glad it worked!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.