"Seize failed" intermittently. Need advice on where to look next

TLDR: Extension assigned to remote campus shows “registered/available” in Asterisk. Incoming calls to extension work fine. Outgoing call attempt displays “Seize failed.”

This does not happen with all similar extensions on the same LAN. It does not happen consistently with the one or two extensions.

I changed physical desksets and the problem remained with that extension. I changed extensions on the original deskset - the problem remained. I deleted the extension in FreePBX and re-created it. Then, a deskset registered and worked properly - until I unplugged the phone and moved it to its final location. Then, seize failed.

The deskset is on a remote campus. It routes to the main campus PBX via VPN and some complicated policy-based routing. I’ve tried to monitor the traffic from a deskset with the failure, but I can’t see any IP-based trafiic being blocked anywhere along the way. The remote phone LAN can ping the PBX. The PBX can ping the failing deskset. Other extensions in the same area work, which makes me believe the routing is okay.

I’ve googled “seize failed” extensively and haven’t found anything to help me diagnose this. I’d like some help identifying where to look next - what log, for example, and what events.

Troubleshooting is difficult because I need to have someone at the remote site to make failed attempts before I can look for anything in the logs.

Thanks for any direction.

Looking at the asterisk log, it does not appear that the phone is contacting the PBX. This is the result of unplugging/plugging (reboot) the phone.

[2023-02-24 12:43:18] VERBOSE[6367] res_pjsip/pjsip_configuration.c: Endpoint 1900 is now Unreachable
[2023-02-24 12:43:18] VERBOSE[6367] res_pjsip/pjsip_options.c: Contact 1900/sip:[email protected]:5060 is now Unreachable. RTT: 0.000 msec

[2023-02-24 12:44:15] VERBOSE[10116] res_pjsip/pjsip_configuration.c: Endpoint 1900 is now Reachable
[2023-02-24 12:44:15] VERBOSE[10116] res_pjsip/pjsip_options.c: Contact 1900/sip:[email protected]:5060 is now Reachable. RTT: 59.036 msec

An attempt to dial produces no entries in the log and “Seize failed” on the deskset.
Another deskset (identical hardware) on the same LAN, same switch, works fine when originating a call - the log shows the call and the call works. Incoming calls to the 1900 deskset work fine.

The line appears as “registered” on the phone GUI and the FreePBX asterisk peers report shows it as available.

Based on the information provided, it seems that the issue is related to the phone not being able to establish a connection with the PBX. The fact that the phone is showing as “registered” and available in Asterisk but is still unable to make outgoing calls suggests that there may be a problem with the routing or firewall settings.

Here are some suggestions on where to look next:

  1. Check the firewall settings on both the remote campus and the main campus to make sure that the required ports for SIP and RTP traffic are open.
  2. Verify the network settings on the phone, such as IP address, subnet mask, gateway, and DNS server, and ensure they are correct and can communicate with the PBX.
  3. Check the routing settings on the remote campus to ensure that the traffic is being routed correctly to the main campus.
  4. Look at the Asterisk logs on the PBX to see if there are any error messages or warnings related to the extension in question.
  5. Try using a different phone model to see if the issue persists. If the problem goes away with a different phone, it could indicate a compatibility issue between the phone and the PBX.

Those were my first thoughts as well. The LAN-VPN-LAN traffic path is any/any for all phone traffic. I’ve verified the network settings on the x1900 phone. It registers with the PBX and it will accept incoming calls. This leads me to believe that the routing is fine.

To verify, I traced packets from the input of the remote LAN router through every interface between the phone and the PBX - I can see traffic passing through every one. And I can see the reply from the PBX go the entire route back.

Other phones on the same remote LAN work with no issues.

The phone that won’t work on the remote campus works fine on the phone LAN here at the main campus, talking to the same PBX.

I did isolate one difference. The phones that work on the remote campus are Aastra 6737i. The phone that says “seize failed” is an Aastra 6757i. Both types are successfully pulling their config from tftpboot on the PBX.

I have a mix of 6737 and 6757 on multiple campuses operating with no issues, but all communicate to their PBX on a local LAN. This is the only installation were they are coming across on a VPN. It’s about a 30ms ping from the PBX to the handset. Virtually no other traffic on the VPN. No NAT.

The asterisk logs have no entries at all around the “seized failed” message.

Just because I hate threads that never reach a conclusion…

I have not determined why this is happening. Replacing the 6757i phones with 6737i phones “fixes” the immediate problem of not having the phones work. The configuration for both is identical, but there must be something about the 6757i hardware that prevents it from working in this environment.

Network communication is (obviously) fine in both directions. And the Polycom 330 phones deployed on the same campus work without issue. As do some Grandstream WiFi phones.

FYI, a little follow-up.

The 6737i phones worked, except for the Xfer button. I did some packet tracing and could see the SIP Invite packet being sent by the phone. I assumed it was not being received by the PBX.

Turns out the vti tunnel was going over a PPPoE connection. Lowering the MTU to 1400 fixed the problem. No more dropped packets and the Xfer button worked.

I’ll be re-trying the 6757i phones to see if that clears up their issues as well.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.