Seeking Cisco SPA50X support

Hi guys,

I can’t figure out how to setup this phone with call parking and BLF features. Feedback/support on forums has been spotty. Would love some help. Anyone have experience configuring Cisco phones and FreePBX? I am happy to pay someone to do a screen share with me and walk me through it.

I suppose you already have one registered and working basically with FreePbx
My SPA504Gs have BLF configured this way:
Advanced mode, Phone tab , LineKey choosen as BLF:
Extension: disabled
Shortname: The display label you want for that button
Share call appearance: private
Extended function: fnc=blf+sd+cp;[email protected]$PROXY;nme=descriptive_extension_name

where extension_number is the extension you want to monitor/BLF and descriptive_extension_name its name.

the same way you can have a “feature” button by placing the "hint"or “feature code” number in place of extension_number

i.e. I have my “call flow” button set as:

fnc=blf+sd+cp;sub=*[email protected]$PROXY;nme=CallFlow

I never associated call parking feature to a button
Just check the right feature code or “hint” and the extension associated,
You can connect to asterisk CLI and type
core show hints

Just my two cents…

thanks digiteltlc! yes, i have basic functions working. I tried your setup for BLF but I am getting flashing orange. Any idea why?

For call parking, I am trying to use one of the LINE buttons to show a parked call, lets call it PARK1. So for example if a call comes in, the recipient of the call can press the PARK1 line button. The call will get parked in that slot. Any other phone can see a call is parked there and press PARK1 to pick it up.

I created a parking lot in FreePBX and used the same fnc= code you suggested above except with the Parking extension, but get a blinking orange light with that one too.

Any feedback welcome!

Just tried Parking BLF succesfully, a note:

$PROXY refers to the actual ip address of PBX you’re going to register to on the LINE KEY 1 , where I suppose you have your main phone extension number.
You can try to replace it with the real IP address:

fnc=blf+sd+cp;[email protected];nme=MyExtension

in case you have more active registered extensions on the same phone (i.e. line key 1 = extension 1000 on pbxA and line key 2 = extension 3000 on pbxB) you must add the BLF line string the line you are referring to:

fnc=blf+sd+cp;[email protected];nme=MyExtension;vid=2

this because you’re going to monitor an extension that resides on same pbx as line key 2

About Call Parking:

First of all I never had Attendant Transfer working on a SPA504 line key, in fact blf+sd+cp starts a “blind transfer”

So, if you plan to set a line key to park a call this way:

fnc=blf+sd+cp;[email protected]$PROXY;nme=CallFlow

It won’t work fine because it parks the call on the first lot available but, being a blind transfer, it won’t give you back audio saying the lot number the call is parked in.

You have to park it “manually” dialing *2 plus 70 (you’ll hear the lot number then hang)

The parking lot BLF works fine instead with the syntax:

fnc=blf+sd+cp;[email protected]$PROXY;nme=Park1

just add as many BLF keys you need to monitor (and your phone buttons permit)
when a call is parked the buttons becomes solid red, pushing it you’ll pick up the parked call

Usually when the button flashes orange, the related HINT (that Asterisk create) is NOT present (you can check as said by typing “core show hints” at asterisk prompt
you should see something like:

[email protected] : park:[email protected] State:Idle Watchers 2
[email protected] : park:[email protected] State:Idle Watchers 0
[email protected] : park:[email protected] State:Idle Watchers 0

(watchers -2 in my case- is the number of phones monitoring with BLF on that hint)

If they aren’t present you should check hints settings on “Advanced Settings” of FreePBX configuration.
Then check in Applications > Parking , that BLF Capabilities is set to Enable
Also check on SPA504 , Attendant Console > Server Type: Asterisk , and Regional: wipe out all Vertical Services Activation Codes

Hope it helps.

hi digiteltlc, all very helpful. Did a factory reset on another phone and BLF worked. However it does seem to require “ext” to be added to the end, like this:

fnc=sd+blf+cp;[email protected]$PROXY;ext=204;nme=MyExtension

I understand what you are saying about call parking – I can’t seem to make a single button that both shows the BLF status AND will transfer a call into the parking spot being represented in the BLF. But i think i have seen it somewhere else. Any other ideas?

Yes, sometimes it also need ext=

About single button …I think it is difficult to achieve, you would need the same button to do an attendand transfer to an extension (70) while monitoring a different one (71) the same time , then how to pick up the parked call if its dialing function is a transfer to 70 ?

What about , if a second call is parked on slot 72 ??? probably you would need to enable just one slot in parking lot.

Let us know if you find something…

In order to get the Call Park button to function properly you need to navigate to the SIP tab of the phone and turn “Keep Referee When REFER Failed” to Yes. If you do not see this option you will need to do a firmware upgrade on the phone ( I believe this option showed up starting 7.4.8 or 7.5.2 not sure which). Once this is turned on a button or softkey (this is how I usually set it up) can be programmed : fnc=sd;[email protected]$PROXY;nme=park and Alison will now announce your parking slot
Hope this helps. It took a lot of digging in the Cisco forums to find it but it works

thank a lot for suggestion,
in fact I was trying in vain to work around the issue with 7.4.8a (where the option is not yet present)
checked in a 7.4.9c it works perfectly
a little off-topic, do you know how to start an attendant transfer pressing a blf+sd+cp button instead of a blind transfer actually achieved ? is it hard-coded into firmware ?

thanks guys. i got the call park situation working but now I can’t answer any calls. I have 3 phones. Each phone uses the first keyline for its own extension. Then I setup each phone to have a keyline with fnc=blf+sd+cp for the other 2 extensions and disabled all the other keylines. I setup a ring group to ring all three phones. When a call comes in, all the phones ring and all the extensions light up, but when I pick up the receiver, I get silence and the caller continues to hear the ring tone. The call actually never connects. Any ideas?

Note: if i can each extension directly, it works fine. Just seems to be an issue with the ring group.

Update: doing some more testing, I noticed if I have 2 extensions in the ring group, everything works fine. As soon as I add a third, then it no longer works – the calls ring but when I pickup the receiver instead of saying “Connected” on the display, it says “Answering.” The call never connects and the caller continues to hear the ringing tone.

I am using a SPA509A.

I had to set the Server Type to Asterisk in the Attendant Console settings. Also I had to change the Attendant Console Call Pickup Code and the Attendant Console Call unPark Code. These have to fit to the Vertical Service Activation Codes in the Regional settings and to the FreePBX settings.

Also, I had to allow my pickup code (in my case **) in the Dial Plan.