Second call not ringing on extension

Hi,

I have an issue with a particular user’s extension. Whenever they are either on an outbound or inbound call, if a call comes from a queue, their extension does not ring anymore as it identifies their line is already busy.
I have set the ring strategy as “ringall” in all our queues and the “Skip Busy Agents” option is set to “Queue calls only(ringinuse=no)”.

This works fine for all other user extensions, where the normal behavior is for the extension to show a second call ringing even if they are on a call already.

What other configurations should I look at on the extension that is having this problem?

Thanks.

Estefanía

Does the extension have call waiting enabled?

Yes, it does.

CW