Scalability and Performance Testing

Hi. I’m doing some performance testing on a server and i’m wondering if I’m seeing “normal” results.

Dell R410
8 Gig Ram
Dual Xeon E5620 @ 2.4Ghz
500Gig SATA 7200 RPM - RAID 1
FreePBX 13.0.143

All default modules are enabled and running. No active calls.

I bulk added the following amount of users and extensions and got these results for ‘Apply Config’:
300 extensions: 20 Seconds
500 extensions: 40 Seconds
1000 extensions: 100 Seconds

(Note: these times seem to be the same for the Dashboard and “Asterisk Info”)

When I run “Appy Changes” my CPU is barely touched.

Does this seem normal? If not, are there any things I can do to optimize the system? Is this a disk io issue? Any feedback would be helpful.


@tm1000 Has been obsessed with this and has been doing a ton of optimization. Some of it may be in edge at the moment.

All of the optimizations were run on a 5000 extension system. I know the 5000 extension reload time was up towards 10 minutes and is now under 2. I am not sure of how time scales up or down per 1000 extensions but it seems you are in the neighborhood.

Edit, looking at commits you are 2 Framework versions behind but should have all the optimizations.

Thanks for the reply. I enabled the edge track, updated all of the modules and set my system back to 1000 extensions. After the initial import the reload took 2 min. I made a username change for one user and reloaded. The second reload took 2 min 45 sec. It kind of seems like i’m hitting the “pre optimized” times.

Alot of the changes are not all published yet but 1000 extensions of 100 seconds is what you can expect. Alot of that time is Asterisk reloading. Its about 50/50 between FreePBX and Asterisk.

If you had tested 3 months ago 1000 users would of been 4-5 minutes.

I reduced the system down to 500 extensions and now with the new modules it it reloads anywhere from 10 to 20 seconds, so that is a big improvement. I’ll keep my eye on things as new updates are released.

Also, I ran into PHP errors when I bulk imported 500 devices into the Endpoint Manager and clicked “Save and Rebuild Configs”. I’ll do some more testing and open a ticket if need to.

Thanks for your help!