SB6850 And SIPStation Trunks

A friend is using SIPStation trunks behind a Motorola Surfboard (SB6850) cable modem - if we enable the SIP ALG inbound works perfectly, but outbound fails with an authentication failure - if we disable the SIP ALG outbound completes the call (no auth error) but there is no audio.

Have you all seen this, and is there any way to work around it? I have tried lots of combinations with SIP NAT settings and ALG settings to no avail.

If not, I am thinking we are going to have to replace the modem with a dumb one that works right.


I would start with making sure al ALG are off. SIP ALG only makes things worse. Then once done reboot the modem.

Make sure your SIP NAT is setup correct in the SIP Settings module but if you have all the ALG off you should not be having issues but who knows if the ALG is truly off.

Have you opened ports 10000-20000 since that is where the audio will come from?

Greg, Is it possible this is a double NAT ( second router behind the moto?)

Also, did you ( with ALG disabled) do any port forwarding rules for 5060 UDP and 10000 thru 20000 UDP on the moto? I am not familiar with that router but you might need firewall “allow” rules as well.

Lastly, if there is no ability to add forwarding, can that router be put into “bridge” mode so you can use a proper router behind it… one that allows proper allow and forwarding rules?

Did not reboot the modem because I could see that turning it off and on allowed outbound to work or not (just without audio) - not a double NAT situation - it’s the only router.

Set up Port Forwarding of UDP 5060 (SIP) and UDP 4000-4999 (RTP - The Ports we use - and set in SIP Settings in FreePBX) and no difference .

Had the same problem a couple of weeks with a Cisco/Comcast Router/Modem where the SIP ALG could not be turned off by the user (and Comcast Wouldn’t turn it off - see here: It is so NOT Comcastic!

We have just been replacing these with dumb modems (SB6121) and either Sonicwalls if they will do it, or Cisco RV042’s (or Netgear’s running DD-WRT if they are REALLY cheap) - this always fixes the problem,