SayUnixTime Gives time an hour behind?

On a FreePBX 2.3. server, I’ve got the right TIme Zone Setup, Webmin shows the correct System Time and Hardware Time (both are identical) , however, when using SayUnixTime, the time playback is one hour behind, at 3:00pm, it sez 2:00 pm. I have had to modify the following

exten => 8463,1,Background(current-time-is)
exten => 8463,2,SayUnixTime(,IMp)


exten => 8463,1,Background(current-time-is)
exten => 8463,2,SayUnixTime(,IMp+1)

as a temp fix, but I installed Nerdvittles reminders and even the reminder time confirmation that is played back is one hour behind!!!. for exampnle, if I set a reminder to come at 13:22, the confirmation message stats you’ve scheduled a reminder for 12:22. The reminder ACTUALLY get delivered at the correct time, i.e. 13:22.

Not really sure where I’ve got anomaly stemming from.

Thanks for any pointer.

If you have the Dialplan Injection module installed, I’d be curious to know how the “Modified Speaking Clock routine” shown on the instruction page at works for you. You may note that it uses a Set(TimeZn=…) before ever getting to the “SayUnixTime” statements. I wonder if that’s what you need to make it work for you.

Note you can also use the Speaking Clock routine as a context in extensions_custom.conf if you put the lines in the proper format. I just find it easier to do it using a Dialplan Injection (and wish that the Dialplan Injection module, or something very much like it, were officially supported). I saw a comment once where someone said they could not get the Dialplan Injection module to work with FreePBX 2.3, but do not know if that was an isolated incident or an actual incompatibility - nevertheless it’s one of the things that’s caused me to hold off on upgrading. So if anyone is successfully using that module with FreePBX 2.3 please add a comment (or if it wouldn’t work for you, I’d like to know that as well).

Somebody else had this issue last week on irc. If I remember correctly they had configured the system the previous day to use NTP and setup the timezone info correctly but the next day it was still saying it wrong even though everyother command was saying it was right. Stopping and restarting asterisk solved the issue.

It’s almost like asterisk read and remembered the timzone offsets on startup and does not re-verify them. That was on a earlier 1.2.1x build.

Maybe the same issue?

Voicemail time and SayUnixtime is fours hours later than system time on my system. Everywhere else the time is correct. Even when I look at voicemail via “Recordings” the time stamp is correct but when listening to the vm the time is four hours off.

try setting TZ=US/Eastern (or what ever the appropriate zone would be in /usr/share/zoneinfo/US) in the file /etc/profile and then restart Asterisk for the new zone to take effect, that is likely the issue. (I don’t think you need to reboot but if the restart fails, you can try that).