SangomaTalk/Connect using wrong port

We have one extension at one deployment where SangomaTalk is trying to connection on (non-TLS) port 5060. The extension was set to auto transport. I removed the user from SangomaConnect, set the extension to explicit TLS re-provisioned the user, reset the app, and resent the invite email. It’s still trying to connect on 5060, plain SIP.

Any ideas?

What type of extension is it?

PJSIP, same as those that are working.

The conventional way to set this up is to have the extension transports be set to “Auto” and configure the Sangoma Talk default transport to TLS.

1 Like

Default in ST is and has been TLS.
Setting for the problem extension was Auto. Same with functioning extension.
Changed the problem extension to 0.0.0.0-TLS for transport, removed the user from ST, re-added to ST, reset the app and re-invited/configured…app is still trying to connect on 5060 (SIP non-TLS).

Update: Tried a different iPhone (14 Pro, iOS 16.1) on the affected extension. Same issue: SIP Log shows the app trying to connect on 5060 and only 5060.

Reset the app and re-provision on a different extension. Works fine.

The SangomaTalk provisioning for this one extension doesn’t seem to be getting done correctly, somehow.

I’m not aware of any reports of this, and I’m unable to repro. Suggest you open a support ticket.

Opened yesterday. Waiting for the assigned engineer to pick it up, though I did call and work it briefly with the person who picked up the phone.

The ticket has been updated with the log file and additional info I posted here. Will update this thread when we get to resolution.

Thank you!

1 Like

Two days after I opened the ticket I got an email asking for unattended remote access setup to the system. We don’t allow that, ever, so I emailed back asking for a call.

No call today, so I deleted the extension and the user and recreated both. That solved the problem. Not sure what was hinky, or even if it was in the user or extension setup, but it’s put to bed for now.

Lol, this is typical for support and very easy…you open port 22 on your firewall and whitelist Sangoma IP…if you have an external firewall you open it up in their too and port forward. This isnt some vudoo snake oil attempt to hack you further.

I do thid every time i open a ticket.