Sangoma Zero touch over WAN

Does the Zero touch work over a WAN. I have some demo Sangoma phones and am trying to set a S300 for zero touch and not getting very far…
I have added option 66 to my router and am pointing it to the ip of the FreePBX server we have.
I am just trying the default Sangoma template for the extension.
I have the extension mapped with the MAC address in the endpoint manager, but when I reboot the phone it does not seem to be directing to the PBX server.
Asterisk 13.14.0
FreePBX 13.0.190.19
S300 firmware image 2.0.4.8

Yes it would work with WAN but you have to make sure you can reach the PBX across the WAN and the firewall allows TFP access

Hmmm. I must be doing something wrong then. Several different brand IP phones here at my location all connect fine and TFTP OK. The S300 works fine when manually configured, but we’re about to deploy 70+ endpoints to one location and I would really love to have this zero touch working

Why don’t you explain more step by step what you are doing.

You talk about zero touch and also option 66 at the same time.

OK. So we have a deployment of FreePBX centrally located in the Midwest. 17 locations connecting to it.
All working fine Mix of Aastra & Grandstream endpoints.
We are going to add one more location in a month. 70+ new endopoints.
Saw the Sangoma phones ate ITEXPO, like the way they integrate with FreePBX and also like the zero touch provisioning. Plug it in, enter ID and password and use it. So I got a Demo pack from Sangoma to try them.
Reading the Wiki it looks like we need to set option 66 in the router of the satellite locations to point to the FreePBX server to get zero touch to work (Unless I’m reading it wrong)
If I understand correctly, when the phone gets it’s IP from the router it should then point it towards the PBX server.
Or have I got it wrong?
The phone is getting a IP, but it’s not going to the PBX. Just all default settings so it needs to be manually configured

For zero touch provisioning to work you will need to register the phone in the sangoma portal, from there you will choose the redirection server and enter the credential needed. For example if you are provisioning via http or https you will select the IP/FQDN then the protocol http or https and in the address bar you will enter it like this

Username:[email protected] OR IP ADDRESS of your machine:port number (phone provision port)

myuser:[email protected]:84
Or
myuser:[email protected]:84

The username and password you will find it under system admin --> provisioning

If you have any questions let me know

The wiki shows 4 ways for the phone to reach the PBX the first time to login. http://wiki.freepbx.org/display/PHON/Auto-Provision+Quick+Start+Guide

You can use any of the 4 options here. Using our redirect server works great for remote phones as you don’t need to set any option 66 on the DHCP server.

Option 4 is great if the phone is on the same LAN as the PBX as it does not require setting anything in the phone, DHCP Server or redirect server. It just works out of the box.

Thanks guys. I’ll try the redirection service instead of the option 66. Played with it all day Friday and got nowhere.
Knowing our users. Option 4 will still be a struggle…

Hi,

I am a little confused in the IP Address/FQDN for PBX in the sangoma portal section i am setting the public ip address of my PBX (if it is behind NAT i 'll have to forward port 83 right ?)

And in the case i ve setup a VPN between the remote phone and FreePBX what IP i 'll hevat to give in the sangoma portal to register my phone ?

Thanks

If you’ve setup a VPN, then you’ll have to enter the PBX LAN IP