Sangoma Voicemail App Setup Problem

voicemail
Tags: #<Tag:0x00007fafc10fdc78>

(Shackbill) #1

On the Sangoma phones we have the envelope/voicemail button set with a default of ‘Voicemail Application’ We noticed on some accounts we would always have a notification to dial *98 to setup mailbox message even on a phone with SIP account with voicemail enabled and that had completed the voicemail setup process.

After further digging, we looked in /var/spool/asterisk/voicemail/default

an ‘ll’ would show some sip extension directories with permission of 755 and some with 775. We set all to 775.

In addition, in /var/spool/asterisk/voicemail/device there are symbolic links for some sip accounts but not all. We tried checking the extension settings to ensure they had voicemail enabled and they had completed the voice mailbox setup. Even after this, they did not have the symbolic link.

For a problem phone and sip account for say extension 25, we applied the following;

ln -s /var/spool/asterisk/voicemail/default/25 25

Once the symbolic link was manually added, the button for voicemail function as desired without always telling the user to use *98 to setup the mailbox even when the user had done so.

It seems like new accounts are working so I am leaning to a bug when we were first setting up sip accounts early on. However deleting the original sip accounts that are causing problems with accessing the voicemail application and re-adding the sip extension isn’t cleaning up the issue even with the latest updates in play, we are going through the process of ensuring the voicemail option is enabled, they have setup the voicemail box and than we have to manually add a symbolic link.

we probably wasted 5 hours trying to track this down and wondered if anyone else has seen this issue and what may be causing it.