Sangoma talk not registering / invite email on iphone

I having a problem with making sangoma talk work on the iphone. It worked just fine when I used google chrome for the invite email. Next time, I used safari on the same phone, but the softphone app did not register. I am not sure if it is a safari problem on the iphone or something else. Since then, I have not been able to make it work on that iphone.

Errors are:

Json webtoken error - jwt malformed
or
API Peer server not connected for session. Please make sure CloudConnect Agent is running on your remote server.

I checked the server. Cloud connect agent is running. Also, other softphone apps which were connected last month are still working fine on the same server. It is a problem with just this new one that I have been attempting to register.

Any ideas?

Thanks,
D

What version of iOS on the iphone? Ran into this same problem today. The iphone was on 16.1.1. They also had another iphone on 16.3 beta and that one connected fine. So they are going to update to 16.2 and see if that resolves the issue.

It did not work on 16.2. I tested just now. It’s like once you try this with safari and it fails, the iphone blocks it at that time. Then, it does not work even with chrome when earlier the invite login link on chrome successfully worked to register the softphone on the same phone.

Can anybody from Sangoma please test this out and let us know if it working when you use safari to open the invite link on iphone?

Please open a support ticket. I would test but don’t have an iOS device. We’re not seeing any reports of this yet.

Did you try the Advanced login in the app and entering email address and password instead of the email login link?

Hi, I had this issue in September. I hope it helps.

—Me—

Despite trying everything I can think of, after an invite it asks for username and password and I get the following error:
JsonWebTokenError: jwt malformed

Occasionally when it has tried to log me in automatically, I get this error, which I have tried to overcome by stopping and starting CloudConnect Agent:
API Peer server not connected for session. Please make sure CloudConnect Agent is running on your remote server.

To be clear, I have a working user, authenticated and online using SangomaConnect on this instance. I’m on an iPhone 7 and assume the customer is using a much newer model, and experiencing exactly the same issues. I am being shown the login screen after stopping and starting CloudConnect following this API message.

—Me—

I was able to replicate and resolve the issue on another instance last night, by removing the domain and certificate in the SangomaConnect module and then adding them again. I’m not sure if that’s the best way of fixing it, noting there is an active authenticated user. I didn’t work on it long enough to see if there is any disruption.

—Sangoma Support—

The best way of getting this certificate back is the procedure you said you have done on the other PBX instance; remove the cert in the Sangoma Connect module using the Run Domain Action button, and then adding the certificate again the same way. I could do this for you on this PBX, but it would temporarily disable Sangoma Connect for the one authenticated user. So you may want to do this at a time when that user does not use Sangoma Connect.

All that will do is trigger a new email invitation, so it’s not a way to work around this issue.

edit - added quote so it’s obvious to whom I’m replying

Our replies came in at the same time, I think @lgaetz is replying to @ozarktech

1 Like

When I tested it from my android tablet, Advanced Login let me sign in directly with email address and the password. I did not get an email invitation. There’s a chance an email notification was sent but I didn’t get it because I don’t have the clients email on my device.

I also have other authenticated users on that system. So, I currently don’t want to try this fix as it is a production server.

I have created a ticket and if sangoma says that the only way to fix it, I may try it after hours.

Thanks for your response.

-D

1 Like