FreePBX | Register | Issues | Wiki | Portal | Support

Sangoma s705 Reboots after login

configuration
Tags: #<Tag:0x00007fcd23509ab8>

(United States) #1

I am having an issue with a Sangoma S705 phone, running on FreePBX. I am using the free version of endpoint manager, and have phone apps working. The issue I am having is that if I log out or log into the phone, the login goes through successfully, and then the phone reboots, and goes into its correct configuration. I believe that this is due to the VLan settings on the network, I have a dedicated voice VLan, which is set up using the phone provisioning template. I am not sure if this would cause a reboot, since the phone never does switch into a different VLan, but I have tried to set the VLan either through DHCP option 132 or the provisioning template, with the same results each time. It makes it difficult to switch two users, as one logs out, the phone reboots, the next one logs in, the phone reboots again, into the user’s settings

I am running the latest firmware and am running out of ideas


(Tony Lewis) #2

The vlan is what’s casuing it. The reason is vlan are template level settings and anytime network settings are changed we have to reboot so when you log out the network settings change since we have no concept of global level default vlan settings. This is going to take a pretty major change in EPM as a feature to handle this. I suggest opening a feature request.


(United States) #3

Would it be possible to make it work if the VLan were configured with DHCP, using option 132? or will the template overwrite it and go back to VLan 0? Is there a way for the phone to check and see if it is really changing VLans? I have tried adding the VLan option to my global config file manually, and the phone still reboots, even when not switching


(Tony Lewis) #4

Currently that would not work. It will always reboot when using vlans. Please open a feature request and we can come up with a idea on how to fix it in some future releae.


(United States) #5

I have disabled the voice VLAN, and the phones are now on the data VLAN. I rebuilt all of the configuration files, but I am still getting reboots on login/logout. Any other ideas as to what would cause this? When I log in or out, the phone says “sync reboot=false”, and then reboots


(Tony Lewis) #6

What firmware are you using?


(United States) #7

3.0.4.53(2018-05-24 16:46:00)
I think I figured it out though. Viewing the syslog through the web interface, it says that a VPN change forced the reboot. No option for it in endpoint manager that I found, but I changed it in the basefile editor and hotdesk works without reboot now


(Lorne Gaetz) #8

When using the phone VPN client, you will see the phone reboot when applying changes. When EPM is generating a new config, the VPN tarball gets built as well and the phone sees that as a change that requires a reboot.


(Tony Lewis) #9

The issue he is seeing is a bug in EPM that @qwell is looking at. When you logout for some reason its enabling VPN in the phone on logout. Which is causing the reboot as its a network change.


(United States) #10

I am not using any VPN though, I have VPN server disabled as well in System Admin pro. Is it a per-user or extension setting?


(Lee Mason) #11

I reverted back to EMP 14.0.2.59 and that seemed to fix the issue. I only went back to this because it was the oldest of the previous versions that I could revert to in the GUI and I wasn’t sure when the bug had been introduced. But at least it fixed the reboot issue.


(United States) #12

For those having similar issues with VPN and VLAN:
I went to the basefile editor and removed P51, for VLan, and and set P8629, for VPN, to 0. Now when I add a phone I have to manually assign it its VLan tag either by logging into its web interface, or through menu, settings, advanced setting, network, vlan. Once it reboots, it will stay on the VLan that was assigned through the interface, and since neither the provision files or the global changes it, the phone will not reboot again when logging in or out.