Sangoma S500 provisions but won't update

I have an S500 on my FreePBX system that will initially provision just fine.

Problem is when I go into EPM and make changes, then tell it to update the device … nothing happens. I am using TFTP as my provisioning option over an external pbx.

I also tried setting the S500 up in my Sangoma portal with the relay option. Again … it initially provisions but I can’t push updates to it.

I have several Yealink phones on the same system. They are updating fine. Here are a couple extra things I have tried:

  1. Disabling the firewall then attempting the push … nothing
  2. Switching to HTTP as my option … I can’t even get it to provision at that point

Any suggestions would be ever so helpful.

Thanks in advance!

It seems likely that the template you are using to provision your phone has an incorrect provisioning URI.

Perfect. That solved it. Thank you, lgaetz.

1 Like

Actually … I thought we were there but still not. This one seems a bit intermittent. I have updated the firmware on my Sangomas to the latest version. I also have them provisioning on http instead of tftp. The phones grab the config file when they boot up … but if I try to update them through the template … they don’t respond. Interestingly, however, some of them occasionally respond and update.

I was seeing through posts that some users were experiencing similar issues via https but http seems like it should play ball. Any other ideas as to why it works one way (phone to pbx) but not the other (pbx to phone)?


What do the logs show. If you are using HTTP when you push the config to the phone in EPM you should see the phone hitting apache logs which will tell you whats going on.

Good call, Tony. I was able to resolve by digging into the logs. Turns out I had two phones competing for the same extension … some rubbish leftover from a previous configuration.

The logs don’t lie … consider this item resolved for good. Thank you!

1 Like

Glad you got it resolved.