Sangoma S500 Phone wont load or connect to VPN [Solved]


(Big Joe) #1

Hi,
I’ve got a problem with a couple of S500 phones that just won’t connect to the FreePBX VPN server.

I’ve got 3 phones all working fine but a couple of others just won’t connect, they all have the same firmware.

They have all been provisioned locally to get the config files but on the ones not working it is like they aren’t receiving the OpenVPN files or something.

They are not making a VPN connection under System Admin > VPN Server.

And if I go to the web server for the phone under Home > Ipv4, next to VPN address it says File Not Exist

I’ve tried factory resets and re-configuring.

Is there away to manually upload the VPN config files?

Does anybody have any pointers where to look further?

BigJoe


#2

I had similar problems last night. After several tries, I was ultimately successful, but not sure what part worked. I did try tftp as the option - that appeared to work once - but not every time.

I did put in the name of the VPN key file in the provisioning tab and clicked auto-provision. They may have worked, not clear again. I was pushing lots of buttons and sometimes it worked and sometimes it didn’t.

I think what was successful was making sure the files were correct on the server & putting in the provisioning address on the web page and then clicking the provision now button. The it provisioned and had the VPN key address on the lower part of the page. Then provisioned again.

Did you check the files are all generated in the /tftpboot directory? And check that you could get them as with whatever permissions you set within the phone?


(Big Joe) #3

brk,
Great help.
Looking in the /tftpboot folder I can see some of the vpn.tar files for the phones that are working but no files exist for the phones that are not working.

So next question any idea how I can force the system to create the vpn.tar files for the missing phones?

BigJoe


#4

Possibly removing the VPN setting from the extension in EPM Extension mapping, then adding it back and regenerating files.

Like I said, I did a lot of clicking. What I didn’t say is that I didn’t take good notes.


(Kapil Gupta) #5

Please make sure VPN is configured properly in EPM. Refer to https://wiki.freepbx.org/display/FPG/EPM-Admin+User+Guide#EPM-AdminUserGuide-VPN

Thanks
Kapil


(Big Joe) #6

Hi Kapil,
I’ve been through the setup over and over.

I enable the client and then click “Save and Rebuild Configs” or “Save,Rebuild Configs and Update Device”.

But it still never generates the tar file for some phones.

BigJoe


(Kapil Gupta) #7

Hi @BigJoe ideally this should be enough to generate vpn tar ball. As you are using commercial module so Please open a commercial support ticket here!


(Big Joe) #8

Support helped with this and the solution was:

  1. ensure the latest firmware is setup for the Sangoma phone in the EPM
  2. ensure the PBX on Sangoma portal is setup with the correct redirection settings under the deployment, for us this was using the FreePBX local ip and http on port 84
  3. register the phone with the deployment
  4. Add the VPN client in EPM and then rebuild
  5. Factory reset the phone (when on the LAN)

Everything then worked OK, the phone got provisioned, tar ball got generated and the phones worked great off site using the VPN.