Sangoma S500 - HOLD Issues


I’m having an issues where my S500 won’t release the hold properly in the remote endpoint.

I have latest FreePBX 13 asterisk 13 and I’m just wondering if there is a simply setting I’m missing before I start delving into debug logs and packet captures.

I’m currently manually provisioning the S500 through its web interface (not EPM at this time due to other issues). I have set up one SIP account and have spread it over the first four line keys (duplicated to make answering call-waiting easier)

This allows me to very quickly switch between incoming calls without fiddling with the arrow keys to go back to other calls on hold.

Placing the first call on hold to answer a second incoming call works fine. The first caller is placed on hold with music.

After spending a few minutes with the second caller and then ending the call, the hangup signals are sent correctly.

However, returning to the first caller who has been on hold a few minutes results in the hold not being released on their endpoint. i.e. the S500 plays back blank audio but the remote endpoint is still on hold with music.

Just tested here at home and not seeing this issue but if your not using EPM then lots of needed settings won’t get set which could result is lots of weird things. We only provide support with Sangoma Phones using EPM. I would start with that and test.

Did you try switching back and forth (not crazy rapidly of course) over the course of about 5 min? SIP over TLS with SRTP?

Also, I would use EPM but I’m having issues, as are other other people getting TLS/SRTP to work with EPM for Sangoma phones.

The web interface is useful as a temporary fallback measure.

You never said anything about SRTP or TLS until now. Asterisk has had lots of TLS issues lately and the last few releases they have tried to fix it. It sure it’s 100% fixed.

As far as TLS and SRTP with EPM. You don’t have to do anything. Set in the extension page to use it and when you have EPM build phone configs it will enable it for you.

Sorry about not mentioning encryption.

I’m also sorry to bug you on Christmas day.

I’m really liking a lot about this phone, I just really want to get it working exactly the way I want.

I’ll give the EPM a try and see if my other EPM issues have been resolved. One bug that I mentioned in a previous post still hasn’t been addressed. The network scan option is reading in a FQDN instead of an IP address which makes me think other items aren’t being read in properly either. (see attachment)

I’ve even tried setting an IP and saving but it still goes back to the FQDN.

Also, TLS and SRTP works great on my current setup except that EPM doesn’t tell the S500 to actually make a call using TLS/SRTP.

Thanks for you help.

It pulls in the network scan from what IP you set as intenral in global settings of EPM.

Also as stated I can provide and assistance to you if you are not using EPM to manage the phones and I just tested and TLS and SRTP work fine when following our wiki on on our phones for TLS and SRTP

If you have issues after using EPM please open a support ticket for assistance on your phone.

Should I not be setting an FQDN instead of and IP for TLS to work properly with my certificate?