Sangoma S500 and Zero Touch Config

I can get to the point of the “Login External” button and after logging in it returns to the same screen. Once you attempt to login the extension and phone MAC will populate in the EPM module in FPBX but thats it. I have to reboot the phone in order for it to pull the configuration profile for that extension.

My environment

FPBX Distro - Latest with all updated modules
Sitting on a hosted VM with public IP
Responsive Firewall enabled and HTTP provisioning services are allowed externally
IP network the phone is on is in Trusted zone
Phone is on LAN
Ext 100 configured for testing
No Extensions are mapped in the EPM
Global settings have been configured with the server’s DNS name

Not sure what I am missing here. I have been told over and over its used widely and works easily but for some reason I have something stopping me.

Thanks in advance for your suggestions.


Ok I guess I’m the only one out there with this issue as I’ve been told there are thousands upon thousands of these phones out there now. How about I ask a different question.

  1. From the portal what is required other than a Server that has been activated and has a deployment ID as well as adding a phone MAC and associating it with the deployment ID ?

  2. From the FPBX EPM module what is required aside from the Internal and or External FQDN or IP addresses in Global Settings as well as the Sangoma Template ip address settings ?

  3. As for the FPBX smart firewall, are any special settings required other than making sure HTTP provision is allowed externally or allowed from Trusted IP networks in the Zones section ?

  4. Are there any special requirements in the Extension settings for a specific extension I am using in order to login to the phone after its redirect from the Sangoma portal ?

If I have missed anything else that needs to be looked into please let me know as I dont know where else to look at this point. We like these phones and would hate to have to return them and move on to a different manufacturer for something that should have been very simple.


I was trying to talk to you on IRC, but you left before I noticed you were there.

Can you tell me what version of Endpoint Manager you’re using? (Go to Module Admin to see)

Sorry yeah have terrible connection here at work. Ill be on IRC tonight. But here is the info.

EndPoint Manager 13.0.61 Stable Sangoma Technologies

Try using - that’s what we use. It’s really good, and free (mostly, but certainly free for someone who only uses IRC casually)

OK, I spent some time with @claudio421 on IRC, and we’ve figured out what the problem is - it was an issue with the way the new configuration is pushed to the phones when they log in.

This is fixed (for everyone, hopefully!) now, and if anyone else has any issues with the zero-touch config on their phones, please feel free to comment here, or open a ticket.