Sangoma Phone Desktop - No Audio Both Ways outside LAN

So Im finally installing the new Sangoma Phone Desktop app to test as I have a client that has an immediate need for the app. They currently have PBXact fully licensed and up to date (v15) and 1000 Sangoma Connect licenses…Anyway

So yesterday I followed the Sangoma Phone Desktop Wiki exactly performing all the steps on our shop FreePBX system (v16 fully updated). Everything went great, Sangoma phone desktop worked without issue on the LAN making and receiving calls on my office PC…

I proceeded to do the same thing to my clients PBXact deployment this morning. Fully updated everything, followed the Wiki exactly. This deployment uses a FQDN, all the ports are forwarded to the PBXact static LAN IP… (We have other remote phones using TLS that have been running great for over a year on this deployment)…

I then installed Sangoma Phone Desktop on my laptop outside my clients network back at my shop, put in FQDN:6443, extension and password. Connects perfectly…can see Favorites list, Presence is working, etc. but any call I make, there is no audio both ways. Cant hear anything and person on other end cant hear anything. I did my typicaly *43 test and I cant here any audio but the call is connected…

Because of this, I jumped back to my office deployment that I first tested Sangoma Phone Desktop on yesterday that is fully working on our LAN… I logged out of Sangoma Desktop on my office PC… Connected my laptop to my 5G hotspot and logged into Sangoma Phone Desktop on my laptop trying to connect to my office deployment to see if the no audio issue when outside the LAN coming in remotely is isolated to just this client…

Connects no problem…same as my clients deployment…can see all my favorites, presence all works, but same issue, no audio both ways…

Both of these deployments (my clients and my own shops) all use Sangoma Connect daily and have for a while. Zero issues with audio with Sangoma Connect…its just with this Sangoma Desktop Phone…

Any idea why I have zero audio both ways on 2 different deployments using Sangoma Phone Desktop with all ports in the Wiki forwarded to the PBX and Sangoma Connect works just fine???

Also, in further testing…Sangoma Phone Desktop on my laptop setup remotely (not on the local LAN) SMS is working just fine… I can also click right on Contacts in my Favorites list, it calls that extension within my company and the phone rings at my employees desk but when answered, again no audio both ways…

So Sangoma Phone Desktop does connect without issue, Contacts/Favorites are all appearing and working, Presence is working and changes when I change to DND, Chat, Away, etc… SMS and Chat is working… Just no audio both ways on calls to both external numbers and internal extensions…

Well, I got audio working both ways. Adding Stun Server address and ICE Host Candidates fixed the issue. After putting those in, 2 way audio is now working for Sangoma Phone Desktop outside of the network…

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.