Sangoma P330 HTTP provisioning with PBXAct not working

You don’t have a provisioning issue, you have a SIP registration issue. If the phone provisions, then it’s unlikely to be a pbx firewall or fail2ban issue. The phone may be misconfigured with the incorrect sip host/port, there may be router misconfig that’s blocking signaling to the PBX. Does external SIP registration work generally?

External SIP registration works 100% fine for ALL other endpoints; the P phones are just showing unregistered

I have 10+ external endpoints registered to this PBXact using this 5062 tcp port and they are working flawlessly (Cisco, Grandstream, softphones…) from various locations and the port is forwarded as TCP only. Does the sangoma P phone also want to send UDP traffic via 5062 for external registration? Maybe I should forward the UDP 5062 as well (I only use TCP for all phone registrations generally).

Also, after the P phone provisions externally, when you press “Reconfigure” on the phone, it shows a BLANK list of “Choose sangoma configuration server” so it forgets the ZTP redirect server upon pressing reconfigure or reboot. There is no such issue with the phones internally since they use mDNS to catch the server

The p phone will use the transport you have specified for the ext. By default it will use udp.

Transport mode in extension’s settings is set to Auto. Even when I set it to the TCP option and rebuild configs in EPM, there is still no difference as it’s still not registering remotely.

Also (probably bug with PBXAct) - in the extension’s configuration in PBXAct, even if I change transport mode, it still displays “This device uses PJSIP technology listening on Port xxxxUDP, xxxxTCP, xxxxTLS” in General tab of the extension’s settings, when the expected behaviour is for it to only show Listening at the transport that is set. For example, if transport is set to only TCP then it shouldn’t display that it’s listening at UDP and TLS as well. Edit: it displays the expected result (only the enabled protocols) AFTER a reboot of the PBX… it should still display only the enabled protocols without need for reboot (it should display correctly after the changes are applied, like with everything else).