Sangoma Linux release 7.5.1805 won't update to 7.6

/etc/redhat-release reported that my system is still running Sangoma Linux release 7.5.1805 (Core)
The last updates in my yum.log dates back to March, so i tried “yum update” to see if it would update to 7.6. It came up with a huge list of updates to install but when trying to download those, each and all of them failed to download. When “Downloading packages:”
package name: [Errno 14] HTTP Error 404 - Not Found
Trying other mirror.
Error downloading packages:
package name: [Errno 256] No more mirrors to try.

The internet connection is fine (calls are working :slight_smile:), i tried what was suggested in
which is “yum clean all” + “rpm -Va --nofiles --nodigest” but now it just keeps reporting that no updates are available. The newer packages that the first “yum update” wanted to install, never made it to get installed and no longer seem available.

The box was still running Asterisk 14, hoping that this would block the update I used “asterisk-version-switch” to upgrade that to asterisk16. This worked successfully but it didn’t unlock the update to 7.6.

Installing sangoma-devel did come up with a bunch of packages to install but reported dependency problems (and I found a post that the devel repo should no longer be used therefore I will not go down that path).

What else can I do to update my box to 7.6 ?

Is there a problem with the Sangoma repositories maybe ? When I try to access the repo in my webbrowser :

I get :


You don’t have permission to access /os/7.6/updates/x86_64/ on this server.

Hi, @remcobar.

We updated our base system to 7.8 a couple of days ago, but due to caching on both yum and our proxies you may not be able to address this just by doing yum clean all after you hit the issue.

In the meantime, we also did some changes on our server to address this problem in a more deterministic manner; if you try it again you should be able to perform the update now.

Listing support was disabled a while ago for security reasons, but if you want to check the repository availability you can always add “repodata/repomd.xml” to the end of the repository’s URL to retrieve its description.

For that particular repo, it would be:

Box is updating from 7.5.1805 to 7.8.2003 now! Thanks for solving the issue


I have the same problem it was mentioned here. I got some FreePBX distro at Sangoma Linux release 7.5.1805 (Core) that can’t be updated. I tried yum clean all -> rm -rf /var/cache/yum/* -> yum update but still no go.

Any help?

Thank you.

I’m having the same problem. After doing the yum clean all, now the system thinks it has no updates to do at all.
The mirrorlist URL is returning:
% curl ‘$dist&staging=$staging

Looks like if I comment out all the mirrorlist directives and renable the baseurl directives, I get a list of updates, cross checking against another server to see if matches.

Looks like what is returned when using ‘baseurl’ is quite similar to what the other server still using mirrorlist (but not having yum clean all" done) returns, but a few packages in sng-pkgs repo are not showing up as needing updating (asterisk13-g729, wanpipe, kmod-wanpipe, kmod-dahdi-linux, sangoma-pbx, sangoma-release).

On the other systems I have that I haven’t done a yum clean all on, a yum update fails with 404s on the sng-pkgs repo files that are needed for the update, like:
wanpipe-7.0.25-3.sng7.x86_64.r FAILED [Errno 14] HTTP Error 404 - Not Found ] 0.0 B/s | 0 B --:–:-- ETA
Trying other mirror.

Error downloading packages:
kmod-dahdi-linux-2.11.1-53.sng7.x86_64: [Errno 256] No more mirrors to try.
sangoma-release-7-8.2003.3.el7.sangoma.x86_64: [Errno 256] No more mirrors to try.
wanpipe-7.0.25-3.sng7.x86_64: [Errno 256] No more mirrors to try.
kmod-wanpipe-7.0.25-3.sng7.x86_64: [Errno 256] No more mirrors to try.
sangoma-pbx-2008-1.sng7.noarch: [Errno 256] No more mirrors to try.
asterisk13-g729-2002-1.sng7.x86_64: [Errno 256] No more mirrors to try.

yum repoinfo is returning different Repo-updated dates, I would have thought the one I did a yum clean all on would return the recent one but is returning a date in July.
On the box I’ve run yum clean all on:
yum repoinfo sng-pkgs
Loaded plugins: versionlock
Repo-id : sng-pkgs/7/x86_64
Repo-name : Sangoma-7 - Sangoma Open Source Packages
Repo-status : enabled
Repo-revision: 1596097942
Repo-updated : Thu Jul 30 08:32:55 2020 <<<<<<<<
Repo-pkgs : 1,336
Repo-size : 3.4 G
Repo-mirrors :$dist&staging=$staging
Repo-baseurl :
Repo-expire : 21,600 second(s) (last: Sat Aug 22 06:00:10 2020)
while on this box that I haven’t done it on:
yum repoinfo sng-pkgs
Loaded plugins: fastestmirror, versionlock
Loading mirror speeds from cached hostfile
Repo-id : sng-pkgs/7/x86_64
Repo-name : Sangoma-7 - Sangoma Open Source Packages
Repo-status : enabled
Repo-revision: 1597091740
Repo-updated : Mon Aug 10 16:36:02 2020 <<<<<<
Repo-pkgs : 1,347
Repo-size : 3.4 G
Repo-mirrors :$dist&staging=$staging
Repo-baseurl :
Repo-expire : 21,600 second(s) (last: Sat Aug 22 01:54:12 2020)

Sunday update

So as of today, my 4 servers now all say the sng-pkgs repo-updated date is July 30th.
Looking at the sng-pkgs repo, the missing packages are not in the repo now (not even earlier versions).
Looking on my testbed VM I made and installed from latest image, rpm says those are from the ‘anaconda’ repo, which appears to just mean was installed during base installation.

A quick check of a few systems today after seeing this thread.

I have one system on 7.8
I have 2 systems on 7.5 that show no updates.

So, any solution to this?

On more thing I can add is that at the Sangoma Linux release 7.5.1805 (Core) system the yum variables are:

  "releasever": "7",
  "basearch": "x86_64",
  "arch": "ia32e",
  "uuid": "7fa5ec7e-122a-4679-8f8d-0b51e0543938",
  "infra": "stock"

while on the Sangoma Linux release 7.8.2003 (Core) the yum variables are:

  "releasever": "7-8.2003.3.el7.sangoma",
  "basearch": "x86_64",
  "arch": "ia32e",
  "uuid": "abbc7290-4e8c-43e3-ae10-3538030deffe",
  "infra": "stock"

@sorvani On the one 7.8 system you have - was that upgraded with yum? Or is it a new installation?
If was via an upgrade, can you do: sudo yum info sangoma-release
and show the output? I’m wondering what repository the package is in…

It was upgraded. It was actually FreePBX 13 originally. Upgraded to 14, then 15.

The update on on the 20th did it.

sudo yum history info 48 shows this.

41 had only this.

hmm, that seems to be saying that sangoma-release was in the sng-pkgs repository at that point. But doesn’t seem to be now as far as I can tell.
This clearly seems to be something on the Sangoma repository side, not clear what since they don’t allow browsing of the repository structure.
Hopefully someone there will read this!

They don’t allow browsing of the repositories “for security reasons”…

So I copied down the yum.conf and the repo files.

I know what zerotier.repo is as I put it there on the BNA system. The ACI system was a clean install of the 2002-2 ISO a month(ish) ago on a demo system that is sitting unused.

The BNA system is the one that is on 7.8, while the ACI system is on 7.5

I downloaded the repomd.xml files from the 3 IPs that resolves to as well as the alternate and they all matched.
I then downloaded the Sangoma-Base repomd.xml file from and the alternate and the files were different:
diff package1-base-repomd.xml mirrorlist-base.repomd.xml | head
< 1587512243. <<< so the one from is a newer revision

> 1543161601

This matches with what I was seeing when I stopped using the mirrorlist source. So I think the question would be why is the sng-pkgs repository not updated as well? (on the package1 server…)

So, Sangoma is not interested in fixing their own repo?

Are you trying to push us away?

I haven’t been following this thread. Can someone share the jira ticket please?

I didn’t see one, so I made one, but this is ancient history IMO. Eight days is a long time to have a repo down. Also a Sangoma employee stated in this thread that you all hosed up cleaned up the repos.

1 Like