Sangoma FXO / FXS Card Won't Start + WebSocket Error

Recently we had a power outage and the Sangoma FXO / FXS card won’t initialize. The error message I’m getting is " DAHDi Doesn’t appear to be running. Click the ‘Restart DAHDi & Asterisk’ button below". When I do this, nothing happeneds. Also after doing a command line restart, I have the following errors on the FreePBX dashboard:

Invalid Websocket transport for zulu
Unable to enable websocket driver!

No conference room app
Neither app_meetme nor app_confbridge is configured in Asterisk, conferencing, paging and other functionality will not work properly

As a result I can’t make or receive incoming calls. My analog trunk is delivered to me via a SPA122 and I’ve confirmed dialtone at the unit. I’ve also confirmed dialtone is going into the Sangoma card. I haven’t tried reseating the card, though I don’t think that’s what the issue is. I’ve also tried a command line update via “yum update”, though no updates where available.

In module admin, I can’t up date Zulu to the latest release until the user manager module is updated, which doesn’t appear to be ready for download.

Current PBX Version:

Current System Version:12.7.5-1807-1.sng7

Total Module Count:117


The numbers below may be inaccurate if new modules have been released since the last check:

Last online check:


Modules with Upgrades:2

System Upgrades Available:0

Please advise as any help would be greatly appreciated.

Thanks Michael

Though I’ve no personal experience with this card, Sangoma has excellent troubleshooting tools.

The info at should let you determine where the trouble lies.

Is FreeSwitch (Fusion) to Asterisk (FreePBX) SIP Trunk Connection still relevant?

If so, it should not be hard to determine the cause of lost registration, fix it and connect directly by SIP… That would give you multiple channels, better voice quality and many other benefits. Who is the provider?

Thanks for the info. I used it to verify the card is being recognized by the system, how ever it isn’t responding to " DAHDi Doesn’t appear to be running. Click the ‘Restart DAHDi & Asterisk’ button below". I’ve also tried “core restart now” to restart asterisk with no effect. Any idea’s?

Thanks in advance for any help that can be provided.

fwconsole stop
fwconsole chown
fwconsole start

If no luck, reboot server, look for any relevant errors in

Next, see DAHDi Doesn't appear to be running , especially the last post.

If still no luck, you might try restoring from a recent backup. If you don’t have one, consider making a backup (so you can get back to where you are now), then seeing whether the FXO works properly in a fresh install.

My personal preference would be to fix or work around whatever required the SPA122 in the first place. Most providers don’t require registration to make calls, so a SIP trunk should work for outbound easily. There is also likely a way to receive calls without registration; who is your provider? If not, it should not be hard to determine why registration is intermittently failing (though it may not be easy to fix).

I’ve restored from last months backup with no success. Please see the consol display from below and the two attached pictures. Do I have a defective card? I haven’t tried moving it to another slot.

[[email protected] ~]# fwconsole start
Running FreePBX startup…
Taking too long? Customize the chown command, See
Setting Permissions…
Setting base permissions…Done
Setting specific permissions…
63096 [============================]
Finished setting permissions
Running Asterisk pre from Dahdiconfig module
Writing out default Sangoma conf
Starting Wanrouter for Sangoma Cards
Wanrouter Started
DAHDi: Already started
Running Asterisk pre from Firewall module
Running Asterisk pre from Pms module
Running Asterisk pre from Sysadmin module
Running Sysadmin Hooks
Restarting fail2ban
fail2ban Restarted
Updating License Information for 61718040
Checking Vpn server
Starting Asterisk…
[>---------------------------] 5 secs
Broadcast message from [email protected] (Tue Sep 25 22:08:05 2018):

Firewall service now starting.

[============================] 6 secs
Asterisk Started
Running Asterisk post from Dahdiconfig module
Running Asterisk post from Endpoint module
Running Asterisk post from Pagingpro module
Running Asterisk post from Restapps module
Starting RestApps Server…
[>---------------------------] 1 sec
Started RestApps Server. PID is 3760
Running Asterisk post from Ucp module
Starting UCP Node Server…
[>---------------------------] 1 sec
Started UCP Node Server. PID is 4053
Running Asterisk post from Vqplus module
RestApps is not licensed.
Running Asterisk post from Xmpp module
Starting Chat Server…
[>---------------------------] 1 sec
Started Chat Server. PID is 4188
[[email protected] ~]#


Thanking you in advance for your help.


I’ve installed the Dahdi card into a different slot on the system, restore a backup from last month and updated all the modules. The card still won’t activate. Any thoughts?

Thanks in advance for any assistance.


Before config anything from GUI, make sure the card is detected by system. please run the command lspci from linux, if card info is there, you then do config from GUI or command setup-sangoma. if no such info, you have to contact sangoma tech support.

Thanks for the information.

I’ve verified that an A200 card is installed.

I’ve then configured the card both through the GUI and the command line. In both cases the DADHI & Asterisk have been stopped and restarted via the built in prompts in the command line or “Restart Asterisk & DAHDI” from the GUI. DAHDI Configuration in FreePBX shows me no ports are available. What am I missing?

Any help would be greatly appreciated. Thanks as always.


Here’s more information on the DAHDI card:

.Any advice is greatly appreciated,


Try a reboot.

Hello Tony
I’ve just completed a hard re-boot with no effect. I’ve tried rebooting with a CO trunk connected in case the card needed to “see” 90V. Is this a power supply issue? I grasping at staws. Is my next step to log a ticket and with whom; FreePBX or Sangoma (or are they the same HelpDesk)? If access is required to the switch I can set this up. Also if this is a bug or hardware issue I’d be more than happy to help troubleshoot the issue. My system is a non production, learning tool; FreePBX 60. Right now I’ve got my Panasonic Cordless phones running off an SPA122.

Any advice or help is greatly appreciated.


Thanks for the help

Is there any other steps I can take before logging a ticket? Whom should I go to; Sangoma or FreePBX or are they both working off the same ticketing system?

Thanks in advance for any help that can be provided.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.