Sangoma Connect Mobile (iOS) Caller ID

I am trying Sangoma Connect Mobile on my iPhone, when I call out from the app, it is using my iPhone caller ID. Why, and is it adjustable to used my registered extension caller ID?

Bump, any ideas on this? It is defeating the point for some of our mobile uses (to not share their personal number, but instead their work number).

I have been googling to no avail, but I cannot believe that we are the first ones experiencing this issue. When I make an outbound call via Sangoma Connect, I do see that it says, in the app, that it is using my cell CID, but there is no setting I can see on the phone or on the server to adjust this.

I’ll reach out to Sangoma as well to see what they say.

Outbound CID is determined by FreePBX not by the client. Are you not seeing the CID that shows in the CDR in the column “Outbound CID” at the far end?

On the CDR the “Caller ID” Field shows as the extension, but the “Outbound Caller ID” field shows the cell phone caller ID of the phone Sangoma Connect is being used on. The Sangoma Connect app also is indicating that it is using the cell phone caller ID, and the call to party is reporting they are getting the call from the cell phone caller ID instead of the Sangoma Connect extension number.