Sangoma Connect Install


(Josh) #1

Hi Everyone-

I am trying to get Sangoma Connect up and running and when I go to enable it for a user I get a red bar at the top stating

  • You are running an old version of endpoint manager that conflicts with SangomaConnect, please upgrade the version of EPM to a greater than (PBX 15) or (PBX 14)

I have tried running through the Module admin to get it to upgrade and I am unable. Currently, it is showing my Endpoint Manager as version 14.0.2.1


(Jared Busch) #2

You have to pay yearly to upgrade EPM. It is only like $26/year or something.

If you are not using EPM then remove it.


(Josh) #3

Thank you for the insight, we are currently paying for it. The big issue is it looks like Sangoma Connect may require it?


(Jared Busch) #4

If you are paying for it, it will update. What version is installed versus available?

[[email protected] ~]# fwconsole ma listonline | grep endpoint
| endpoint             | 15.0.27.43 | Enabled and up to date                       | Commercial  |

(Josh) #5

[[email protected] ~]# fwconsole ma listonline | grep endpoint
| endpoint | 14.0.2.1 | Enabled and up to date | Commercial |
| endpointman | | Not Installed (Locally available) | GPLv3+ |


(Josh) #6

I just tried to cheat and run fwconsole ma downloadinstall endpoint --tag 15.0.27.43 and I get an error stating Unable to update module endpoint - 15.0.27.43, it does not exist:


(Lorne Gaetz) #7

If you’re not using the free version of EPM, it requires an annual maintenance renewal to get upgrades:
https://wiki.freepbx.org/display/FPAS/How+to+Renew+FreePBX+Commercial+Modules+Maintenance

If you don’t want to upgrade, you can enable Sangoma Connect for a user, but you must remove the extension mapping in EPM, then add it back once Sangoma Connect is enabled.
https://wiki.freepbx.org/display/CONNECT/Technical+Details+and+Limitations#TechnicalDetailsandLimitations-EndpointManager


(Jared Busch) #8


(Josh) #9

I am not sure how I missed that, but my modules expire in 2043, but only free updates until 2017. It looks like I may have to disable the mapping.


(Jared Busch) #10

That means you have not paid for renewals in years. EPM is significantly out of date. You need to upgrade it.


(system) closed #11

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.