Sangoma connect bogging down server

I think that’s what going on here. Cpu usage on the VM is 100% and I see in the /var/log/asterisk/sangomaconnect_out.log about 20 of these a second

Connecting to PBX
SangomaConnect Daemon running on port 8443

Not sure where to set a port number for sangoma connect. I dont see it in the firewall nor do I see it in port management in sysadmin. EPM support is up to date and the restapps module that seems to break everything is up to date as well as is the sangoma connect module. Tried restarting sangoma connect, asterisk, and the pbx but no change.

Any suggestions?

PBX Version:
PBX Distro: 12.7.8-2203-2.sng7
Asterisk Version: 18.9

At some point around 4 hours ago this seems to have fixed itself. Not sure what to make of that…

So I dont think anything is actually fixed, at 6:01 am the sangoma connect server shut down. The app still works though.


I noticed that there were too many zulu users compared to the amount of licenses, so that was fixed and it cleared up some of the messages in the log. I also saw that the EPM license had expired so that was fixed and all modules are updated. Still getting tons of these in the pm2 log

2022-11-09T12:16:48: PM2 log: App [sangomaconnect:18] starting in -fork mode-
2022-11-09T12:16:48: PM2 log: App [sangomaconnect:18] online
2022-11-09T12:16:48: PM2 log: App [sangomaconnect:18] exited with code [1] via signal [SIGINT]

Not sure what to do about it.

I see the certificate is gone, is there an easy way to have sangoma connect recreate it? I tried sending a text from the app and got this:

It was the certificate that did it. Run Domain Action → Update Certificates. CPU usage is down from 100% to 10%.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.