Sangoma A500 ISDN Elastix Setup

I have used Elastix a number of times previously when dealing with analogue lines but not ISDN. I have recently purchased a Sangoma A500 3 port ISDN card. I installed Elastix 2.4.0. Once installed I put the card in and detected the hardware. The card is found and all the channels. Then I created ten extensions 101-110, a ring group 600 with all the extensions. I created a Dahdi trunk referencing g0 in the Dahdi identifier and setting 12 as the maximum channels and using . and XXXXXXXXX as dial plans. I also created an outbound route that uses the Dahdi trunk and the same dial plans as the trunk. I have plugged an ISDN cable into one of the three ports on the card. My extensions are registered etc, but when making calls I get all circuits are busy. Here is my dahdi-channels-conf file:

; Span 1: WPBRI/0 “wrtdm Board 1”
group=0,11
context=from-pstn
switchtype = euroisdn
signalling = bri_cpe
channel => 1-2
context = default
group = 63

; Span 2: WPBRI/1 “wrtdm Board 2” (MASTER)
group=0,12
context=from-pstn
switchtype = euroisdn
signalling = bri_cpe
channel => 4-5
context = default
group = 63

; Span 3: WPBRI/2 “wrtdm Board 3”
group=0,13
context=from-pstn
switchtype = euroisdn
signalling = bri_cpe
channel => 7-8
context = default
group = 63

; Span 4: WPBRI/3 “wrtdm Board 4”
group=0,14
context=from-pstn
switchtype = euroisdn
signalling = bri_cpe
channel => 10-11
context = default
group = 63

; Span 5: WPBRI/4 “wrtdm Board 5”
group=0,15
context=from-pstn
switchtype = euroisdn
signalling = bri_cpe
channel => 13-14
context = default
group = 63

; Span 6: WPBRI/5 “wrtdm Board 6”
group=0,16
context=from-pstn
switchtype = euroisdn
signalling = bri_cpe
channel => 16-17
context = default
group = 63

Have you considered to give FreePBX Distro 5.211.65-13 (Stable) a try and then configure your Sangoma A500 ISDN Card (which is Certified to work with FreePBX) by enabling, updating and configuring the relevant FreePBX DAHDI Configuration module?

A nice video here.

Another good source of information to debug Sangoma Cards could be this page (FreePBX indipendent) or, since you’re testing that card using Elastix 2.4.0, this specific Sangoma document.

Hi Parnassus, many thanks for the reply.

I have followed This guide but the issue still exists. All circuits are busy.

I have also looked at this link however,according to the top, the wanpipe is already installed, so I am not sure whether I need to follow the other instructions on this page. I figured I would try to follow the guide excluding the install of the wanpipe driver and I get stuck at this part rpmbuild -bp dahdi.spec

I also tried the section on configuring Sangoma Cards using the command wancfg_dahdi. But I am still in the same boat. I am downloading FreePBX now, so hopefully I will know in the next couple of hours if I will be successful using this instead.

Anything else you can think of let me know, but your help is much appreciated.

Forgot to tell you that, once the FreePBX Distro will be up and running, before any configuration give to FreePBX Modules a check to see if they are all updated (especially dahdiconfig that should be at least version 2.11.42 or 2.11.43), via CLI or via FreePBX GUI (Module Admin) so you have a fully updated system and any issue could be discussed starting from this fact; via CLI these are the relevant commands:

module_admin a ma listonline

and then a:

module_admin a ma showupgrades

then, if any, upgrade with:

module_admin a ma upgrade MODULENAME

where MODULENAME is what appears on lists.

After perform always a:

module_admin a r

That’s like to hit the “Apply” button on the FreePBX GUI.

More info about managing FreePBX Modules via CLI here on the Wiki.

I will certainly do this. Installing it now, so will be sure to follow your instructions. Many thanks again.

I have now installed freepbx with the A500 and despite a few small issues (no card detected etc) I now have the card showing and configured.

Just for some other background info, we do have a working PBX in the office from a paid company that uses the Sangoma A500 BRI card in TE mode that is working. Here is a shot of the card setup (I believe this has custom versions of asterisk etc)

I have taken two of the ISDN lines form this PBX and using in the FreePbx one I am trying to configure.

Here is the configuration at the moment:

I have tried sangoma on both T and E, but still receive the all circuits are busy message.

In the asterisk log or trace (not sure what I would call it) I can see this line:

Executing [[email protected]:1] NoOp(“SIP/104-00000000”, “TRUNK Dial failed due to CONGESTION HANGUPCAUSE: 27 - failing through to other trunks”)

Shouldn’t you define at least one Dial Pattern rule (or, eventually, a series of rules) on your defined Outbound Route “Main” in order for an outgoing call to be correctly processed and routed to available Trunk you’ve created (DAHDI Channel g0)?

From the screenshot you attached I see no rule at all…

I have added one dial pattern with a match pattern of “.” (as in Full-stop), in both the trunk and outbound route. I am under the impression this acts as a catch all. But I will certainly take the time to define them clearer.

I can’t get back to it till Monday. But using

asterisk -rvvvv

Then using

pri show spans

I am able to see the active spans, however, they are showing as disconnected. I will test a few variations and post results ASAP.

If you could answer this though, when using a Sangoma card is it necessary to click the sangoma option and select “yes” for “Run Wanpipe in Dahdi/Digium Mode” for the card to show up and also what option should be selected “T” mode or “E” mode? I have not yet found this in the docs, so if you could point me in the right direction it would be much appreciated.

Many thanks for sticking with me!!!

Hi, I’m not an expert of Sangoma PSTN Cards but I think you could find an explanation for the presence of that new DAHDI parameter here (read the comments about how wanpipe configuration is generated by pulling data from DAHDI). Initially there were two parameters and then Developers unified them in just one, see here.

Regarding the E1/T1 parameter I think the E1 mode for ISDN Primary Rate Interface is used most in Europe countries (The ISDN PRI line is known as S2m and it has 30 B channels + 2 D channels) than in North America (or elsewhere the T1 is used out of Europe)…but your Card isn’t a PRI one, just a BRI AFAIK. Differences here.

Forgot to mention the FreePBX Wiki DAHDI Config page here.