Sangoma A400 - Outbound Dialing

I have a Sangoma A400 installed and working with 8 POTS lines.

Incoming works fine.

Outbound only works on 1 line.

If an outbound call is made on a POTS line, and another outbound call is attempted on an available POTS line while the first call is in progess, after a few seconds the user attempting the second call gets a busy signal.

Setup put all the channels in the same group (g0). I edited the DAHDI config file to assign a different group to each line, made a trunk for each group, and then added all of the trunks to the outbound route… Still not working.

Is there a basic guide to configuring FreePBX to use a Sangoma card once the card is installed?


You don’t need to put each channel in a group, simply put the channel number in the DAHDI channel field in FreePBX. This is covered in the tool tip if for DAHDI trunk.

My opinion is you are having glare issues. Remember to select your outbound trunks in the opposite order of inbound calls to minimize the potential for contention, called “glare” in telco terms.

Thanks, Skyking, for the present and past help.

I’m using Trixbox CE and I don’t see a “DAHDI Channel Field” option in the FreePBX settings.

As an aside, since Trixbox seems long dead now, how hard would be to upgrade to something newer? If so, what’s best for a small office setting? Is there anyway to keep my setings intact, or is it better to start from scratch.

I’m a lawyer, not a techie, though I did manage to get the thing working a few year ago.

In the bottom of the DAHDI trunk is the channel field, where you put the ‘g’

We have a script to convert your trixbox to the official FreePBX distro. It may be more appropriate for you to use support. They can take care of the upgrade for you.

I called and left a message on the support voicemail.

I have a love/hate relationship with computers in general and telephony in particular…

All kinds of ambition, but woefully, not much aptitude.