Sangoma A200 Pci in ne Dell T40 (EFI boot) freepbx 15


(Edward) #1

I changed from a Dell T20 to T40.
I installed from scratch in the new DELL T40
Now my Dahdi channels are not answering calls. Or Dialing out.
I tried all bios settings on the T40

If I move this install HD and Sangoma A200 card back to the old DELL T20 everything works.

Someone suggested that since the T40 does not support Bios BOOT mode only EFI it has problems detecting the A200 PCI card.

Would a PCIe A200 work?

Or am I looking in the wrong place?

rgds,

Datatech


(Dave Burgess) #2

Since DAHDI is a separate program from Asterisk and FreePBX, you might need to look at the dahdi support programs that should be installed on your system.

lspci is a good program to start with - it should give you insight into whether the dahdi hardware it installed. From there, there are a couple dozen dahdi support programs in the /usr/local/bin (I think) directory.

If the hardware supports it and the card is configured correctly, look through the /var/log/asterisk/full log file to find where Asterisk is enabling the dahdi subsystem and make sure there are no errors.

Switching from a T20 to a T40 shouldn’t make any difference as long as you have the same DAHDI hardware in the machine. Also, you should be able to set the BIOS to not use the EFI boot, which might generate another result.


(Edward) #3

The T40 does not support switching to BIOS boot mode only EFI.
On the T40 I can see the card via lspci.
wanrouter status also sees the card
I can also see the Dahdi channels. asterisk -rx “dahdi show channels”

It just does not respond to incoming or outgoing calls.
If I move the HD and A200 to the T20 everything works. This is Why I don’t believe it is a configuration issue


(Dave Burgess) #4

What do the logs say?


#5

If wanrouter sees the card, then DAHDI should also see it, provided it is correctly configured.


(Edward) #6

on incoming. Logs do not register anything.
On outgoing . I see that it uses Dahdi/1-1 but no other logs register.

I just installed Esxi6.7 and installed a Freepbx15 VM in Bios mode (NOT EFI) with A200 passthru card and now I can make and receive calls.

Tonight I will try one more time baremetal with this working backup and post the logs


(Dave Burgess) #7

That usually means that the driver connection from the DAHDI subsystem to Asterisk is not working. There should be several references to DAHDI and dahdi (case matters) in the /var/log/asterisk/full log file as the Dahdi subsystem initializes and connects to the dahdi process, which should already be running from the ‘fwconsole start’. If dahdi isnt’ starting, what you’re seeing makes sense.


(Edward) #8

THIS ARE MY LATEST TESTS

Installed ESXI 6.7 on the DELL T40 and created a VM (Bios mode) with the A200 in passthru.
Everything works fine.

I deleted this one and created a new VM (EFI mode) with A200 passthru.
Cannot dial or receive calls.
output from “wanpipemon”
image

As you can see same configs. But the EFI mode VM shows “Line: uninitialized”
I can even see voltage changes when a call is coming in via wanpipemon. But asterisk does not register anything.

Does anyone think I will get the same result if I use an A200 PCIexpress instead of PCI?
My other option is to get an older server that supports changing BIOS mode to “BIOS” instead of “UEFI”

Last resort is keeping Freepbx as VM in BIOSmode.
However I do not want to do this if it going to be a standalone machine.


(system) closed #9

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.