Sangoma A101 "all circuits are busy now"

Hi All,

Im having problems with outgoing calls - I get the well documented “all circuits are busy now…” when attempting any outgoiung calls.

Asterisk is version 1.4.23.1
FreePBX core is 2.5.1.7
Installed via AsteriskNOW.

Below is the CLI output on attemting a call:

asteriskCLI>
Extension Changed 207[ext-local] new state InUse for Notify User 206
Extension Changed 207[ext-local] new state InUse for Notify User 203
– Executing [[email protected]:1] Macro(“SIP/207-09cc0cc0”, “user-callerid|SKIPTTL|”) in new stack
– Executing [[email protected]:1] Set(“SIP/207-09cc0cc0”, “AMPUSER=207”) in new stack
– Executing [[email protected]:2] GotoIf(“SIP/207-09cc0cc0”, “0?report”) in new stack
– Executing [[email protected]:3] ExecIf(“SIP/207-09cc0cc0”, “1|Set|REALCALLERIDNUM=207”) in new stack
– Executing [[email protected]:4] Set(“SIP/207-09cc0cc0”, “AMPUSER=207”) in new stack
– Executing [[email protected]:5] Set(“SIP/207-09cc0cc0”, “AMPUSERCIDNAME=Joel”) in new stack
– Executing [[email protected]:6] GotoIf(“SIP/207-09cc0cc0”, “0?report”) in new stack
– Executing [[email protected]:7] Set(“SIP/207-09cc0cc0”, “AMPUSERCID=207”) in new stack
– Executing [[email protected]:8] Set(“SIP/207-09cc0cc0”, “CALLERID(all)=“Joel” <207>”) in new stack
– Executing [[email protected]:9] Set(“SIP/207-09cc0cc0”, “REALCALLERIDNUM=207”) in new stack
– Executing [[email protected]:10] GotoIf(“SIP/207-09cc0cc0”, “1?continue”) in new stack
– Goto (macro-user-callerid,s,19)
– Executing [[email protected]:19] NoOp(“SIP/207-09cc0cc0”, “Using CallerID “Joel” <207>”) in new stack
– Executing [[email protected]:2] Set(“SIP/207-09cc0cc0”, “_NODEST=”) in new stack
– Executing [[email protected]:3] Macro(“SIP/207-09cc0cc0”, “record-enable|207|OUT|”) in new stack
– Executing [[email protected]:1] GotoIf(“SIP/207-09cc0cc0”, “1?check”) in new stack
– Goto (macro-record-enable,s,4)
– Executing [[email protected]:4] AGI(“SIP/207-09cc0cc0”, “recordingcheck|20090511-085239|1242028359.324”) in new stack
– Launched AGI Script /var/lib/asterisk/agi-bin/recordingcheck
recordingcheck|20090511-085239|1242028359.324: Outbound recording not enabled
– AGI Script recordingcheck completed, returning 0
– Executing [[email protected]:5] MacroExit(“SIP/207-09cc0cc0”, “”) in new stack
– Executing [[email protected]:4] Macro(“SIP/207-09cc0cc0”, “dialout-trunk|2|9118118||”) in new stack
– Executing [[email protected]:1] Set(“SIP/207-09cc0cc0”, “DIAL_TRUNK=2”) in new stack
– Executing [[email protected]:2] GosubIf(“SIP/207-09cc0cc0”, “0?sub-pincheck|s|1”) in new stack
– Executing [[email protected]:3] GotoIf(“SIP/207-09cc0cc0”, “0?disabletrunk|1”) in new stack
– Executing [[email protected]:4] Set(“SIP/207-09cc0cc0”, “DIAL_NUMBER=9118118”) in new stack
– Executing [[email protected]:5] Set(“SIP/207-09cc0cc0”, “DIAL_TRUNK_OPTIONS=tr”) in new stack
– Executing [[email protected]:6] Set(“SIP/207-09cc0cc0”, “OUTBOUND_GROUP=OUT_2”) in new stack
– Executing [[email protected]:7] GotoIf(“SIP/207-09cc0cc0”, “0?nomax”) in new stack
– Executing [[email protected]:8] GotoIf(“SIP/207-09cc0cc0”, “0?chanfull”) in new stack
– Executing [[email protected]:9] GotoIf(“SIP/207-09cc0cc0”, “0?skipoutcid”) in new stack
– Executing [[email protected]:10] Set(“SIP/207-09cc0cc0”, “DIAL_TRUNK_OPTIONS=”) in new stack
– Executing [[email protected]:11] Macro(“SIP/207-09cc0cc0”, “outbound-callerid|2”) in new stack
– Executing [[email protected]:1] ExecIf(“SIP/207-09cc0cc0”, “0|SetCallerPres|”) in new stack
– Executing [[email protected]:2] ExecIf(“SIP/207-09cc0cc0”, “0|Set|REALCALLERIDNUM=207”) in new stack
– Executing [[email protected]:3] GotoIf(“SIP/207-09cc0cc0”, “1?normcid”) in new stack
– Goto (macro-outbound-callerid,s,6)
– Executing [[email protected]:6] Set(“SIP/207-09cc0cc0”, “USEROUTCID=”) in new stack
– Executing [[email protected]:7] Set(“SIP/207-09cc0cc0”, “EMERGENCYCID=”) in new stack
– Executing [[email protected]:8] Set(“SIP/207-09cc0cc0”, “TRUNKOUTCID=01527880051”) in new stack
– Executing [[email protected]:9] GotoIf(“SIP/207-09cc0cc0”, “1?trunkcid”) in new stack
– Goto (macro-outbound-callerid,s,12)
– Executing [[email protected]:12] ExecIf(“SIP/207-09cc0cc0”, “1|Set|CALLERID(all)=01527880051”) in new stack
– Executing [[email protected]:13] ExecIf(“SIP/207-09cc0cc0”, “0|Set|CALLERID(all)=”) in new stack
– Executing [[email protected]:14] ExecIf(“SIP/207-09cc0cc0”, “0|SetCallerPres|prohib_passed_screen”) in new stack
– Executing [[email protected]:12] ExecIf(“SIP/207-09cc0cc0”, “1|AGI|fixlocalprefix”) in new stack
– Launched AGI Script /var/lib/asterisk/agi-bin/fixlocalprefix
> fixlocalprefix: Using pattern 9|.
== fixlocalprefix: Dialpattern 9|. matched. 9118118 -> 118118
– AGI Script fixlocalprefix completed, returning 0
– Executing [[email protected]:13] Set(“SIP/207-09cc0cc0”, “OUTNUM=118118”) in new stack
– Executing [[email protected]:14] Set(“SIP/207-09cc0cc0”, “custom=DAHDI/g0”) in new stack
– Executing [[email protected]:15] ExecIf(“SIP/207-09cc0cc0”, “0|Set|DIAL_TRUNK_OPTIONS=M(setmusic^)”) in new stack
– Executing [[email protected]:16] Macro(“SIP/207-09cc0cc0”, “dialout-trunk-predial-hook|”) in new stack
– Executing [[email protected]:1] MacroExit(“SIP/207-09cc0cc0”, “”) in new stack
– Executing [[email protected]:17] GotoIf(“SIP/207-09cc0cc0”, “0?bypass|1”) in new stack
– Executing [[email protected]:18] GotoIf(“SIP/207-09cc0cc0”, “0?customtrunk”) in new stack
– Executing [[email protected]:19] Dial(“SIP/207-09cc0cc0”, “DAHDI/g0/118118|300|”) in new stack
– Requested transfer capability: 0x00 - SPEECH
– Called g0/118118
– DAHDI/1-1 is proceeding passing it to SIP/207-09cc0cc0
– Channel 0/1, span 1 got hangup request, cause 1
– Hungup ‘DAHDI/1-1’
== Everyone is busy/congested at this time (1:0/0/1)
– Executing [[email protected]:20] Goto(“SIP/207-09cc0cc0”, “s-CHANUNAVAIL|1”) in new stack
– Goto (macro-dialout-trunk,s-CHANUNAVAIL,1)
– Executing [[email protected]:1] GotoIf(“SIP/207-09cc0cc0”, “1?noreport”) in new stack
– Goto (macro-dialout-trunk,s-CHANUNAVAIL,3)
– Executing [[email protected]:3] NoOp(“SIP/207-09cc0cc0”, “TRUNK Dial failed due to CHANUNAVAIL (hangupcause: 1) - failing through to other trunks”) in new stack
– Executing [[email protected]:5] Macro(“SIP/207-09cc0cc0”, “outisbusy|”) in new stack
– Executing [[email protected]:1] Playback(“SIP/207-09cc0cc0”, “all-circuits-busy-now|noanswer”) in new stack
– <SIP/207-09cc0cc0> Playing ‘all-circuits-busy-now’ (language ‘en’)
– Executing [[email protected]:2] Playback(“SIP/207-09cc0cc0”, “pls-try-call-later|noanswer”) in new stack
– <SIP/207-09cc0cc0> Playing ‘pls-try-call-later’ (language ‘en’)
– Executing [[email protected]:3] Macro(“SIP/207-09cc0cc0”, “hangupcall”) in new stack
– Executing [[email protected]:1] ResetCDR(“SIP/207-09cc0cc0”, “vw”) in new stack
– Executing [[email protected]:2] NoCDR(“SIP/207-09cc0cc0”, “”) in new stack
– Executing [[email protected]:3] GotoIf(“SIP/207-09cc0cc0”, “1?skiprg”) in new stack
– Goto (macro-hangupcall,s,6)
– Executing [[email protected]:6] GotoIf(“SIP/207-09cc0cc0”, “1?skipblkvm”) in new stack
– Goto (macro-hangupcall,s,9)
– Executing [[email protected]:9] GotoIf(“SIP/207-09cc0cc0”, “1?theend”) in new stack
– Goto (macro-hangupcall,s,11)
– Executing [[email protected]:11] Hangup(“SIP/207-09cc0cc0”, “”) in new stack
== Spawn extension (macro-hangupcall, s, 11) exited non-zero on ‘SIP/207-09cc0cc0’ in macro ‘hangupcall’
== Spawn extension (macro-outisbusy, s, 3) exited non-zero on ‘SIP/207-09cc0cc0’ in macro ‘outisbusy’
== Spawn extension (from-internal, 9118118, 5) exited non-zero on ‘SIP/207-09cc0cc0’
– Executing [[email protected]:1] Macro(“SIP/207-09cc0cc0”, “hangupcall”) in new stack
– Executing [[email protected]:1] ResetCDR(“SIP/207-09cc0cc0”, “vw”) in new stack
– Executing [[email protected]:2] NoCDR(“SIP/207-09cc0cc0”, “”) in new stack
– Executing [[email protected]:3] GotoIf(“SIP/207-09cc0cc0”, “1?skiprg”) in new stack
– Goto (macro-hangupcall,s,6)
– Executing [[email protected]:6] GotoIf(“SIP/207-09cc0cc0”, “1?skipblkvm”) in new stack
– Goto (macro-hangupcall,s,9)
– Executing [[email protected]:9] GotoIf(“SIP/207-09cc0cc0”, “1?theend”) in new stack
– Goto (macro-hangupcall,s,11)
– Executing [[email protected]:11] Hangup(“SIP/207-09cc0cc0”, “”) in new stack
== Spawn extension (macro-hangupcall, s, 11) exited non-zero on ‘SIP/207-09cc0cc0’ in macro ‘hangupcall’
== Spawn extension (from-internal, h, 1) exited non-zero on 'SIP/207-09cc0cc0’
Extension Changed 207[ext-local] new state Idle for Notify User 206
Extension Changed 207[ext-local] new state Idle for Notify User 203
asterisk
CLI>

I have seen in many posts that people have refered to the file “zapata.conf” however the Wanpipe drivers for the A101 were installed for Dahdi and so i presure these zap conf files wouldnt be created.

I have got a chan_dhadi.conf - contents is as follows:

;autogenerated by /usr/sbin/wancfg_dahdi do not hand edit
;autogenrated on 2009-05-09
;Dahdi Channels Configurations
;For detailed Dahdi options, view /etc/asterisk/chan_dahdi.conf.bak

[trunkgroups]

[channels]
context=default
usecallerid=yes
hidecallerid=no
callwaiting=yes
usecallingpres=yes
callwaitingcallerid=yes
threewaycalling=yes
transfer=yes
canpark=yes
cancallforward=yes
callreturn=yes
echocancel=yes
echocancelwhenbridged=yes
relaxdtmf=yes
rxgain=0.0
txgain=0.0
group=1
callgroup=1
pickupgroup=1
immediate=no

;Sangoma A101 port 1 [slot:4 bus:9 span:1]
switchtype=euroisdn
context=from-pstn
group=0
echocancel=no
signalling=pri_cpe
channel =>1-6

I have set up trunk g0 in FreePBX and setup Outbound routes - i can see reference to this in the CLI output so i dont think the routes are the problem.

I would also add that inbound is fine - no problems with DID’s etc.

Service is ISDN30 provided by BT.

Please let me know if i can post any further information to assist with figuring out what is going on here. I have spend the last few days reading post after post but havent found anything as yet which has helped so far.

Thanks,

Joel.

Have you tried to use the zaptel emulation mode instead of using a custom trunk?

To do that edit the amportal.conf file and add this line:
ZAP2DAHDICOMPAT=true
save the config and issue the following Linux command: amportal restart

It will then allow you to create a regular zaptel trunk using the dadhi setup.

This is the information on it from the file:[code]# ZAP2DAHDICOMPAT=true|false

DEFAULT VALUE: false

If set to true, FreePBX will check if you have chan_dadhi installed. If so, it will

automatically use all your ZAP configuration settings (devices and trunks) and

silently convert them, under the covers, to DAHDI so no changes are needed. The

GUI will continue to refer to these as ZAP but it will use the proper DAHDI channels.

This will also keep Zap Channel DIDs working.[/code]

Also from the log you posted, it appears that your dialing 9118118 and stripping the 9 and sending 118118 to the trunk. Is 118118 a legitimate number in your area?

Hi,

Thanks for the replies. I have checked amprtal.conf and it was already set:

ZAP2DAHDICOMPAT=true|false

DEFAULT VALUE: false

If set to true, FreePBX will check if you have chan_dadhi installed. If so, it will

automatically use all your ZAP configuration settings (devices and trunks) and

silently convert them, under the covers, to DAHDI so no changes are needed. The

GUI will continue to refer to these as ZAP but it will use the proper DAHDI channels.

This will also keep Zap Channel DIDs working.

ZAP2DAHDICOMPAT=true

Will our ISDN30 card have the Zap Identifier as g0 when it comes to trunk naming? - I cant see a way to find out and from reading other posts it looks like g0 is fine if there is only one adaptor installed in the machine?..

As for the number 118118 then yes, it is a legitimate number… its one of many directory enquiry numbers which all begin 118 in the UK.

Thanks,

Joel.

If you have that then use the regular zaptel trunk configuration and don’t attempt to use the custom trunk.

I take it you are referring to the lines…

– Executing [[email protected]:13] Set(“SIP/207-09cc0cc0”, “OUTNUM=118118”) in new stack
– Executing [[email protected]:14] Set(“SIP/207-09cc0cc0”, “custom=DAHDI/g0”) in new stack

I am currently looking at my Trunks page in FreePBX at the trunk ZAP/g0 which says it is a ZAP Trunk (DHADI compatibility mode)in use by 1 route, which is my single Outbound Route…

I have tried deleting this trunk and creating a new one but still the result is the same.

Is there anything else i can check?

Thanks.

I have been searching for a resolution to this problem since my last post and im getting nowhere.

I am under pressure to find another solution if we have to go another week with this issue and obviously I just want to make FreePBX/Asterisk work.

If people could take another look at the problem then i would appreciate it.

Cheers.

Call the folks at Sangoma. They have a great tech support department.

Hi,

I think I am having a similar problem with a digium TDM410P card in the UK.

Did you manage to sort out the problem that you had, if so please could you share the solution.

Go to my website to view more Zaptel and Dahdi info then you care to know.

I am using Dahdi drivers, please see my thread which has more details:

http://www.freepbx.org/forum/freepbx/installation/all-circuits-busy-message-when-dialing-out-using-fxo-port-in-uk-help