Sangoma 60 intermittent ring alert


(Yannick PG Martin) #1

Hello,

I’m having a issue where the calls being transferred from a Sangoma Vega 60 to a PBXAct 14.0.13.40 (Asterisk 13.19.1) are not ringing intermittently on the PBX’s Polycom phones. By intermittently I mean the calls can only be answered when the phone is ringing. The users have to wait for each intermittent ring to answer the call.

I don’t see anything in the CLI to illustrate an issue. I don’t see anything in the Vega settings. I have tried using a longer ringtone, changing the Asterisk Trunk Dial Options but its the same outcome. The transferred calls can only be answered when the phone is ringing.

The Vega is acting as a gateway for two POTs lines. One for a Vonage line, the other for a door system. Both act the same way, hence the issue lies somewhere with the Sangoma and its connection with the PBX. The trunk is a pjsip trunk and while I got the Vega Gateway Manager to work it always says that my Vega is down so its safe to say the manager is not working.

Any help is welcomed.

Thank you


(Yannick PG Martin) #2

No takers, no replies, comments.


(Lorne Gaetz) #3

Start with sharing a call trace via pastebin
https://wiki.freepbx.org/display/SUP/Providing+Great+Debug#ProvidingGreatDebug-AsteriskLogs-PartII


(Yannick PG Martin) #4

Many thanks Lorne,

The trace shows that the call hangs up after every ring.

https://pastebin.freepbx.org/view/5a577cfb


(Lorne Gaetz) #5

It’s early here, and I’m only running on a half cup of coffee, but it looks like the inbound call only rings for 5 seconds, stops and sends the call again. I don’t think this has anything to do with the local extensions, and I assume if you call from extension to extension everything works fine.

Your provider may be able to tell you why this is happening. As a work around, there is an advanced option on your inbound routes to ‘force answer’, that may fix this but it would be preferable to get your trunk setup correctly.


(Yannick PG Martin) #6

This is not a provider problem, it’s a Vonage POTS line. This is a Sangoma Vega 60 trunk problem. I will try the force answer.

I have tried both a PJSIP and a SIP trunk, but they all act the same. Perhaps there is something wrong with the trunk config for the Vega, but if you have ever configured one of these there’s not much to it. I can’t seem to find out how to setup the trunk “correctly” or better. Outbound and inbound work minus this headache.


(Yannick PG Martin) #7

Well the force answer works, but it is not ideal. The call continues to ring but there are other complications.

I revisited the configuration using the following for channel PJSIP and for SIP:
https://wiki.freepbx.org/pages/viewpage.action?pageId=125436194
https://wiki.freepbx.org/pages/viewpage.action?pageId=125436078

The result is the same for both the PJSIP and the SIP trunk. The inbound call rings, hangs up and then rings again.

In each case the trunk is configured as presented in the wiki and the Sangoma and the Asterisk server display the trunk as registered. Nevertheless the problem remains.


#8

Perhaps you have some Vonage signalling on the trunk like MWI that is interfering, If you plug in a good old analog phone do you hear a ‘stutter’ dial tone?


(Yannick PG Martin) #9

Would have to check that tomorrow. Would that apply to the FXO port or the FXS?
I’m currently using only the FXO ports.


(Yannick PG Martin) #10

The Vonage connection also is the very basic using the “Quick Config” as shown in the wiki.
When you use that the configuration is simplified, so no MWI interference.


#11

It’s been a while since I used a vonage device but ny default voicemail is turned on and signals with a ‘stutter’ dial tone, If you don’t use it

https://support.vonage.com/articles/answer/Turn-Voicemail-On-or-Off-9256

which would definitely stop the ‘stutter’ , If you have any residual voicemails you should read and delete them on the “Vonage Portal”


(Yannick PG Martin) #12

I will look into this but the issue is not isolated to the Vonage line. There are two POTS connections. One is the Vonage, the other is a door system. They both react in the same manner thus my isolation of the problem being with the Vega.


#13

Perhaps if you have two lines, you might have ‘split pairs’ where tip or ring of one pair, is connected incorrectly to the other pair, unplug one line and see if the problem changes, Another thing to check is if the Vonage hardware has a common ground then perhaps an inverted pair ?