Samgoma a200 Outbound calls Solved

Hello i bought a Samgoma A200 card from ebay. Somehow i it to work inbound calls with a long delay which i think that is okay. But my problem is the outbound calls. I try to set it up by setting up a DAHDI in the trunks for inbound and outgoing calls. Then i went to inbound calls and pointed it to my ext to only be called in. And when i call out i get a Busy signal. Sense I’m still new to FreePBX and linux i have no clue what to do in setting up outbound calls can someone please help me. I just want to set it up so only one Ext can call out on Port 1 of the analog card? Please help me and walk me through this. I have been to the wiki pages and many other forum pages. I’m so lost.


What outbound routes do you have in your system? Post the settings of each route. Also if you have access in the asterisk cli run the following command and post the output.

dahdi show channels

Hello thank you for the reply back.

let me take screenshots.

First clean your trunk from any patterns. You have outbound routes to manipulate how to dial out from the trunk.
In your outbound route fill all the CallerID fields with the extension that you want to only dial from your trunk, also make one pattern to test things out because you might have some errors in your patterns. Just fill the prefix with number 9 and the pattern field with . then try to call with the 9 as your prefix e.g. 95551234567. If you can make calls then you can check your patterns if they are ok thus making calls without a prefix. If you cannnot make a call even with the prefix then check that you cable is connected to the right analog port and try again. You have two dahdi channels so you need two trunks to access them both or one with g0 as the dahdi identifier.

Hello Astbox i blankout the caller id part in the screenshot so no one sees it. deleted the outbound stuff in the trunk. But still unsure about the outbound route part of the prefix and what 9 is for? can you show me a example?


Hello I’m able to dial out now with this outbound setup

But i now can not here nothing no sounds. Not even if i call a Ext?

You just had the cable on the first analog port and not the second that you were using in your configuration. Try to use analog channel 1 in your dahdi trunk.

What do you mean you cannot hear sound? Give an example.

Hello no the analog phone line is on port 2 i didn’t change that. The server is at my work and that is 4 hours drive or 2 hours train ride. I just searched around google for ( freepbx outbound route analog trunk example usa ) and went through a few into it worked. and found this one.

Now for the sound. Somehow yesturday i was about to call from my home ext to the work ext and i was able to here sound and talk with no problem. Now i can not here no sound nor speak nothing happens. so no sound. No one touched it and i have the only access to the login and setup. Not sure if it is something i did. I do not know.

Do you register remotely to your box?

Yes i can remote ssh into it.

No ssh, do you use a softphone to register remotely to asterisk server?

Hello oh yes i have a sip Polycom phone i tested on and also i have a Sip software application on my pc i was able to use. i got the sound to work. somehow in the asterisk sip settings i forgot when i moved the server to the other ip address i forgot to tell it to detect external ip address in the network network for the sound. Now that works. This morning i went into work and found the server dead Well hard drive failed. The server was a old server was really for test to see if i can use it or not. I thought it would hold out on the PBX. So now i put in new hard drive install everything all over again I’m able to call in and have sound But i do not remember how i did the call out part. So i looked at my old notes from this post trying to recreate the same settings as the last part and so far no luck.

Somehow i think the Pattern is off. I’m not sure Sense I’m in the usa and my area code is 609.

I’m sorry for all the trouble I’m now able to make incoming and out going calls. Thank you all for the help. Onto my next Quest problem.