safe_asterisk: line 145: Segmentation fault

uname -r

debian lenny

I had a 1.4.38 asterisk with freepbx 2.6.0 that I updated to
all was good… no issues

deceied to upgrade to 1.8 I tried in dec 2010 and it was messy had all sorts of issues… felt it was not time…

today I grabbed


/usr/src/asterisk-1.8.4-rc2# ./contrib/scripts/
/usr/src/asterisk-1.8.4-rc2# ./configure
all good
make menuconfig
select app_mysql, app_saycountpl, cdr_mysql, format_mp3, res_config_mysql
go to Extras Sound Packages
Save & Exit
make install

Wow no issues… so I did the next best thing try out the latest
/usr/src/freepbx-2.9.0beta2# ./start_asterisk start
/usr/src/freepbx-2.9.0beta2# ./install_amp

I gave it a reboot
checked to see if asterisk or safe_asterisk was running (ps -A)
it was not so I ran

amportal start

Fetching FreePBX settings…

Permissions OK

/usr/sbin/safe_asterisk: line 145: 4250 Segmentation fault (core dumped) nice -n $PRIORITY ${ASTSBINDIR}/asterisk -f ${CLIARGS} ${ASTARGS} > /dev/${TTY} 2>&1 < /dev/${TTY}
Asterisk ended with exit status 139
Asterisk exited on signal 11.
Automatically restarting Asterisk.
/usr/sbin/safe_asterisk: line 145: 4310 Segmentation fault (core dumped) nice -n $PRIORITY ${ASTSBINDIR}/asterisk -f ${CLIARGS} ${ASTARGS} > /dev/${TTY} 2>&1 < /dev/${TTY}
Asterisk ended with exit status 139
Asterisk exited on signal 11.
Automatically restarting Asterisk.
Asterisk Started

FOP server is already running

killall safe_asterisk

/usr/sbin/safe_asterisk: line 145 <— is the run asterisk command


Any Ideas… serching here and googling is not bring up a whole heck of alot of hope for me?

I deleted /usr/lib/asterisk

and ran amportal start… it complained but ran… I should deleted this when I started

It had my g729 from 1.4 in there… its messy… so I am recompiling again… deleting all the spots then trying over…

/usr/src/asterisk-1.8.4-rc2# make uninstall
rm -f "/usr/lib/asterisk/modules/*"
rm -f /usr/sbin/asterisk
rm -f /usr/sbin/astgenkey
rm -f /usr/sbin/autosupport
rm -rf /usr/include/asterisk
rm -rf "/var/lib/asterisk/firmware"
rm -f /usr/share/man/man8/asterisk.8
rm -f /usr/share/man/man8/astgenkey.8
rm -f /usr/share/man/man8/autosupport.8
rm -f /usr/share/man/man8/safe_asterisk.8
make -C sounds uninstall
make[1]: Entering directory /usr/src/asterisk-1.8.4-rc2/sounds' rm -rf /var/lib/asterisk/sounds rm -rf /var/lib/asterisk/moh make[1]: Leaving directory/usr/src/asterisk-1.8.4-rc2/sounds’
±-------- Asterisk Uninstall Complete -----+

  • Asterisk binaries, sounds, man pages, +
  • headers, modules, and firmware builds, +
  • have all been uninstalled. +
  •                                       +
  • To remove ALL traces of Asterisk, +
  • including configuration, spool +
  • directories, and logs, run the following +
  • command: +
  •                                       +
  •         make uninstall-all            +


I will let you know …

in the http://myip/admin/config.php

I have this error

retrieve_conf failed, config not applied
Ignore this
Reload failed because retrieve_conf encountered an error: 1
Added 23 minutes ago

I deleted just the /etc/amportal.conf and freepbx.conf and dumped the databased and redid them like it was a new system
Should I be deleting all the older files from asterisk and freepbx before I install

asterisk -crvvv

Asterisk 1.8.4-rc2, Copyright © 1999 - 2010 Digium, Inc. and others.
Created by Mark Spencer [email protected]
Asterisk comes with ABSOLUTELY NO WARRANTY; type ‘core show warranty’ for details.
This is free software, with components licensed under the GNU General Public
License version 2 and other licenses; you are welcome to redistribute it under
certain conditions. Type ‘core show license’ for details.

== Parsing ‘/etc/asterisk/asterisk.conf’: == Found
Unable to connect to remote asterisk (does /var/run/asterisk/asterisk.ctl exist?)

thats it it just dies

I was also going to ask if you had a version of DAHDI built against 1.4, you could have had the old chan_dahdi module.

You need to watch carefully when you do the make install as the installer will complain if any bad modules the installer will spit out an error.

I fought with it… freepbx 2.8 and latest 2.9 both when I try to add a trunk complained of tables missing. I am not sure of the exact error

but I finnaly did a freepbx.2.7.0 and changed the detect to 1.9 so I could get past the 1.8.4 part then added a trunk and happy for now… til I have more energy to see why freepbx 2.9 2.8 can not handle adding a trunk under 1.8.4