S705, WiFi, EPM

Setting up our first Sangoma 705 phone here. Seeing a number of issues, using the same template that is working with 30+ 500s.

  1. Background image isn’t loading on the phone. It is on the 500s.
  2. WiFi config added to the template just doesn’t work; if the phone is booted without an Ethernet cord it doesn’t connect.
  3. Vertical buttons are programmed but don’t load.

Have put firmware 1.42 in slot 1, which is where we load it, but that didn’t fix anything.

EPM is up to date.

Anyone been successful with the S705 and EPM config?

I am having similar problems with the S705. It is a bi**h to get provisioned, and the background image won’t load. I am constantly loading up the latest firmware in the hope that these problems will get fixed. My biggest problem is provisioning. The last one I did would not provision when the phone was not on the same network as my PBX. I now have two more, and am struggling to get them to provision.

Have you opened bug reports or support tickets? Without them any bugs won’t get reported or fixed by the staff.

Thank you, Tony. I opened a ticket around 1:00 PST today and then immediately called in. I did not reach anyone and without a gold/upgraded support code the system timed out and all I could do was hang up. I didn’t get a call back.

I did, however, get the phones mostly working. I had to remove them from EPM, delete the extensions entirely, recreate extensions and then create in EPM, reset the phones to default, and then let them provision over a wired Ethernet connection. This fixed the wifi issue and left them functioning. But the background image still doesn’t load and there are ring tone issues: A user chosen tone in the phone GUI reverts back to the config setting, even though the template is set to let the GUI override, and for the 705s, the template is set to Ring 2 but they still use Ring 1. Hopefully support will call back and we can get fixed.

Tony - I submitted a support ticket today.

I also have an EXP-100 attached to my S705 phone. I made a change to the template, but I could not get the phone to update until I did a factory reset of the phone. Then the template update showed up. Meanwhile, I have to go to the remote site, grab the phone and bring it back to the same subnet as my PBX, and allow it to provision. What a pain!

I was thinking about it a while ago.

Wifi is obviously wireless and will never be the same as a wired connection. And… some use a Ubiquity AP Pro Wifi Antenna, and some use (especially remote home users) their ISP Modem that has a cheap antenna.

How is this supported?


If you are having to bring the phone onto the LAN to get config updates it sounds like you have the phone setup to contact the PBX for provisioning using the LAN IP and not external IP of the PBX or you do not have the ports opened on your firewall to let the phone get updated configs.

I run a Exp 100 on my S705 and have no issues here.

As far as wifi the phone has to join the wifi to be able to get on the network if you are using 100% wifi otherwise how does the phone get to the PBX the first time. Most users set it up with LAN and get it configured than switch it to wifi after its been configured for this very reason.

We have no direct support to specific Access Points. All we do is let you connect to a AP so it has to be something the phone can reach and good coverage.

OK, I just got off a call with Sangoma tech support. I was provisioning my phones with TFTP, and he confirmed that there are problems with the 705. It was not requesting the configuration file. We switched my provisioning to HTTP, and it worked. Also after a reboot, the background screen showed up. The 705 is working correctly now.

1 Like

Glad they were able to assist you. Ya I never use TFTP and never saw mentioned here you were using TFTP as most people do not use it since its not secure and does not work well over a WAN.