S705 audio extremely choppy


(Bryce Holland) #1

OK, please tell me that I am not going crazy! I have two S705 phones with an expansion unit for the main office of a school. After about 3-4 days of use, all of the audio (ringing, earpiece, microphone) becomes extremely choppy and unusable. The secretary described it as a low signal cell phone call. Here are the steps I have taken so far:

  • Replaced patch cables
  • Moved to a new drop
  • Upgraded firmware (2.0.4.67 for the phone, 2.0.5.0 for the EXP100)
  • Installed system and module updates in PBXAct

All phones on that floor used the same switch with a dedicated fiber uplink. All of the S505 phones do not exhibit this behavior. In addition, another school client with the exact same S705 phones do not have this issue.

Is there anything else I can check? Restarting the phones resolves the issue for another few days.


(Lorne Gaetz) #2

Notify flood could cause this issue. Are you using PJSIP for the extensions? If so, set the MWI subscription to solicited for the extensions.


(Bryce Holland) #3

Thank you for your reply. Yes, I am using PJSIP. However, I just finished a support ticket with Sangoma about MWI. There is a bug in their recent module versions that causes the voicemail indicator to not light up when set to Solicited. Besides, this problem happened when I did have it set to solicited (it’s now unsolicited).


(Bryce Holland) #4

Just wanted to post again to ask if anyone else had any ideas? My last desperate idea is to switch these extensions to Chan_SIP, but I really don’t want to do that since I would lose some functionality.


(Ruler2112) #5

I was going to chime in and let you know that I had this same type of thing with the phones I ordered from Sangoma, but that a firmware upgrade fixed it. Unfortunately, you’ve already tried that & have the same firmware revision that my phones are on, so it’s of no help. :frowning_face: My implementation does use chan_sip though - the lack of a setting to disable NAT prevents me from using pj_sip across the board & I did not want to mix technologies.

Don’t know what type of infastructure you have, but if you have the ability to perform a packet capture of traffic going to/from the device while it’s giving the choppy audio, it should tell you if it’s a problem with the line being saturated or something else. (I suspect the latter given that a reboot temporarily fixes the issue, but still might give you a clue.) I know many gateway devices have the ability to do packet captures on them nowadays & if yours does not, most/all managed switches have a port mirroring feature that you could set up to dump traffic to another machine.

One other thing you might want to try is to swap phones to see if the problem moves… might just be a flaky DSP or something inside the phone.


(Bryce Holland) #6

Thank you for your reply. I was able to open a ticket with Sangoma for this issue. There are about a dozen S505 phones connected to the same switch on the same VLAN, and they do not have this trouble.
We theorized a packet flooding issue with MWI on the “Unsolicited” setting in the extension. This is a known issue with PJSIP that the developers are working on to resolve. We have set the MWI to “Solicited” (which stops the voicemail indicator light from working), but then manually set a few options on the phones themselves to bring back the indicator light. We’ll see in a few days if this resolved the issue for now.


(Edwin) #7

Bryce can you share the ticket #? Thanks.