S500 was working before some Module updates

My S500 was working out of the box for over a year, then some Module update, unsure which one, caused the phone to quit registering.

I reverted to an earlier backup, but it has not fixed.

I manually updated the firmware to, no dice, however now the phone keeps trying to update the firmware even though it is on the newest.

Is there a way to force a firmware downgrade? I have put much older firmwares in slot 1 and 2 in EPM, this doesn’t work. It stays, and manually trying to install an older firmware doesn’t work either.

Is there a way to connect to the phone via console and force install of older firmware?

We are experiencing the same thing. Installed module updates over the weekend and firmware updating on all of our phones has gone haywire. The only thing that I’ve had luck with is editing the basefile and disabling firmware checking on the phones by setting this to “2”.

We also tried rolling back the EPM version and that did not fix it.

P238# Upgrade Check Mode 0 - Always Check For New Firmware, 1 - check new firmware only when F/W pre/suffix changes, 2 - Always Skip The Firmware Check

I have also noticed that when the phones start doing the firmware check loop, the ROM version on the phone shows “n/a”. Manually upgrading the firmware on the phone to the matching version in EPM seems to temporarily fix it, but the next time the phone checks in it goes into a loop again without disabling firmware checking.

Are the accounts on the phone authorizing properly? The firmware update loops, for me, only started after I stated having an issue where the phone was getting the “Registration Failed” error. Didn’t dig in the logs (couldn’t remember which log to check), so I don’t know the cause of the failed auth.

Maybe two separate problems for me.

While the firmware update is showing up on the screen, if I go to the phone web interface it does show as “registration failed”

The phone gets through most of the initializing phase and stops on “Updating firmware, please wait…”

I am able login to the phone web interface before it reboots again, but all account registration shows as failed.

I’ve seen it occur on almost all of our s405 phones (around 120) and a handful of our s705 phones until I disabled firmware checking in the basefile edit.

taskprocessor output is too long to post and my account is too new to post links…
edit: pastebin / ANi4NykJ

The phone will sit at upgrading firmware while it updates firmware. Your issue seems almost like your firmware on the server is corrupt so it can’t apply it and keeps trying to. Have you logged a support ticket so someone can assist you debugging what’s going on.

Thanks, that got me looking closer at the firmware update itself.

In the phone log I saw this:

[06-07 09:49:31 51:4b:51] TFTPC: timeout! there is no data arrived!
[06-07 09:49:31 51:4b:51] TFTPC: Timeout waiting for data (errno: 11 == 11 n: -1)
[06-07 09:49:31 51:4b:51] TFTPC: Data recieve Timeout. Aborting transfer
[06-07 09:49:31 51:4b:51] RTOS Upgrade: ROM, ======>> Get sangoma/1/fw705.rom Fail, ret -1<<======
[06-07 09:49:31 51:4b:51] rom_file_check: file /tmp/fw705.rom length should be 12387368 real is 131072 !
[06-07 09:49:31 51:4b:51] ------------------------------------------------------
[06-07 09:49:31 51:4b:51] Free Memory Info:
[06-07 09:49:31 51:4b:51] memfree: 30348KB buffers: 40KB cached: 11904KB
[06-07 09:49:31 51:4b:51] Total free memory: 42292 KB
[06-07 09:49:31 51:4b:51] ------------------------------------------------------

[06-07 09:49:31 51:4b:51] RTOS Upgrade: ROM, Func upgrade_rom_file, Upgrade Boot and Img success, Reboot Now!!

So it seems that something is stopping tftp from completely transferring the file… I changed my provisioning protocol to HTTP and the phone booted up properly!

@bcourtade Thanks for letting us know. I’ll be taking a look at this to see if I can figure out why tftpd might not be sending all of the data.

@jcbdmd Can you confirm that switching to HTTP solves your issue too?

Yes, that fixed it for me as well. It also allowed the firmware downgrade. I am going to apply latest firmware and make sure everything is working, but it does look like a TFTP issue.

I cleared out all Sangoma configs and firmwares from tftpboot directory as well and re-setup everything.

This is a TFTP issue. TFTP server from upstream CentOS has made changes to allow faster downloads for RFC7440 which now has side affects. I suggest using HTTP for the mean time. We are trying to change the defaults on TFTP for the distro and push a new RPM out so it works again and also look at making a change to our phones so if they only get part of the firmware instead of rebooting it just boots and ignores that it was not able to upgrade until you manually reboot it again.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.