S500 on TLS: Couldn't negotiate stream 0:audio-0


#1

I got two endpoints connected. One being Linphone, and the other is an S500 (with latest firmware). The Linphone client is client is functioning as expected. I am using a certificate from Let’s Encrypt

The S500 is showing registered, but the line key backgrounds are black instead of green.

When trying to make a call, this is the only information displayed from the basic log:

ERROR[18932]: res_pjsip_session.c:934 handle_incoming_sdp: 1000: Couldn’t negotiate stream 0:audio-0:audio:sendrecv (nothing)

I took a peek at this page to see if I had missed anything, but it looks all good:

https://wiki.freepbx.org/pages/viewpage.action?pageId=64946938

Any ideas on this?


(Dirk2358) #2

By chance, I had exactly this error the first time today, too. It turned out, that configuration of the extension in FreePBX required encrypted RTP, but the incoming SDP didn’t provide it. That’s why pjsip says, that there is no codec to negotiate - which is pretty the truth. Or maybe the same error message is coming up, if the incoming SDP doesn’t provide any of your configured codecs in FreePBX. But a SIP trace can show you more. In the asterisk cli enable SIP trace with

pjsip set logger on
pjsip set logger pcap file.pcap

The log file may be found at /var/lib/asterisk/file.pcap
You can examine the pcap file with wireshark.


#3

I am seeing a SIP 488

SIP/2.0 488 Not Acceptable Here

Which I am reading which normally refers to CODEC issue. Does not make sense me as all the same CODECS are available on both client extension, and the PBX. And the fact Linphone is WFM on same account.


PJSIP outbound proxy issue
(Joshua C. Colp) #4

488 is not just codec issue. It also applies to what @dirk2358 said - if one side is trying to do SRTP, but the other is not configured to do so.


#5

Ah, yes.

in Account - > Advanced there is an SRTP setting:

srtp

Thanks for helping me understand this!