S500 issue with vlans

I have the auto provisioning set in the Sangoma Portal.

The phones update their firmware (currently, connect to my PBXact server, and pull down the configuration.

I press the login button, login, the phone sets up it’s screen with the correct configuration from Endpoint Manager, pulls the correct vlan configuration, and then it sits there.

It does not request a new ip. When I go into the phone’s status, the IP is

When I unplug the phone and plug it back in to reset it, it then pulls the correct IP and everything works as it should.

I am not sure if I have a misconfiguration or this is a bug.

That’s correct. Vlans require a reboot because it’s a network change. Login specifically tells the phone not to reboot so it doesn’t reboot as that ruins the experience for everyone who doesn’t use vlans so you will have to reboot them when you use login and enable vlans in the config. It’s a 1 time thing.

That makes sense, but why can’t the phone be like “Did I have a vlan set/changed? No? Don’t restart. Yes? Restart.”

I can see this making bigger deployments with vlans more difficult. I would have to leave a note with every phone “After you login for the first time, wait 15 seconds and unplug then replug your phone from/into the wall or it won’t work.”

Seems like a feature that really needs to be there.

I wish it was that easy. Human logic is always easy. The issue is currently we jump through hoops to keep it from rebooting unless firmware change and that was hard to get right. Afraid this would cause to many false positives. But please put in a feature request and we can get it into the queue to look at.